Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,I´ve got the same problem that the one in this post: It was “solved” (in that post) reinstalling centreon packages but it doesn´t work for me.Could you please give a hand? I´m a bit lost.It happened after an update (OS + Centreon) and an import of some resources via CLAPI.Centengine error:“/usr/sbin/centengine: symbol lookup error: /usr/lib64/nagios/cbmod.so: undefined symbol: _ZN3com8centreon6broker8LogEntryC1EPN6google8protobuf5ArenaEb”No errors on database log. No errors on broker log. No errors on apache/php logs…Almalinux 9.Centreon Centreon Engine 24.10.4 (according to the browser).Standalone server with MariaDB. No pollers.I´ve tried:dnf reinstall centreon-clib dnf reinstall centreon-broker\*dnf reinstall nagios*dnf reinstall centreon*… with NO success.Restarting server or centreon/db services doesn´t help.Something strange:In the browser I see version:24.10.4 but the installed packet version is: 24.10.5-1centreon-24.10.6-1.el9.noarchcentreon-auto-discovery-server-24.10.3-1.e
Bonjour, Sur postman je fais un GET pour récupérer la liste des service_id et host_id d’une liste de host :{{baseUrl}}/configuration/services?{{baseUrl}}/monitoring/hosts?search={"$or":[{"host.name":{"$eq":"SYN_JEAN-PHILIPPE-RAMEAU_0781107E-JPR-AP17"}},{"host.name":{"$eq":"SYN_JEAN-PHILIPPE-RAMEAU_0781107E-JPR-AP16"}}]}&limit=50&page=1 Mais ce code me ramène tous les champs avec le host_id et les services id. Je souhaite voir que les services_id et les hist_id
Hi,we use Centreon 24.10.5 IT edition with the new Dashboard feature.We created a new dashboard and added some data.As logged in user everything is fine: When using the public link from a shared playlist it looks like this:Wrong data in Active VPN Users and Wireless Clients. The data-type for all three numbers is a separate meta service. Can you please help with the issue? And is it possible to round the values in the display? Thank you
Hello everyone.We are currently facing an issue with the Azure Virtual machine plugin. We monitor 13 VM, and every time, at least 3 of them appears (randomly and it can be 4-5-6) as DOWN in our GUI. While the rest of the service associated to the VM works like a charm. When launching the following command from the poller with the --debug argument I get the following :== Info: TLSv1.3 (IN), TLS handshake, Newsession Ticket (4):== Info: Connection state changed (MAX_CONCURRENT_STREAMS == 100)!=> Recv header: HTTP/2 200=> Recv header: cache-control: no-cache=> Recv header: pragma: no-cache=> Recv header: content-length: 663=> Recv header: content-type: application/json; charset=utf-8=> Recv header: expires: -1=> Recv header: strict-transport-security: max-age=31536000; includeSubDomains=> Recv header: x-content-type-options: nosniff=> Recv header: x-ms-ratelimit-remaining-subscription-resource-requests: 97=> Recv header: x-ms-request-id: 142788ce-1818-4a30
Hello, I have a similar error tohowhever here this happens on the built-in check_centreon_plugins from https://github.com/centreon/centreon-nsclient-build/releases/tag/20221115 Here is the command executed by centreon:[centreon-engine@centreon-central ~]$ /usr/lib/centreon/plugins//centreon_nsclient_restapi.pl --plugin=apps::nsclient::restapi::plugin --mode=query --timeout='30' --hostname='EXCH2.exemple.com' --port='8443' --proto='https' --legacy-password='*******' --command=check_centreon_plugins --arg='apps::microsoft::exchange::local::plugin' --arg='replication-health' --arg=' --warning="" --critical="not %{result} =~ /Passed/i"'UNKNOWN: Cannot decode json response: malformed UTF-8 character in JSON string, at character offset 2454 (before "\x{fffd}0080\\u009Ap...") at /usr/lib/centreon/plugins//centreon_nsclient_restapi.pl line 162.[centreon-engine@centreon-central ~]$ Here is the successful check done locally on the monitored server itself:Here is the check done locally on the
Hello,I have this error :[2025-04-02T18:53:32+02:00] CRITICAL : [CentreonDb] Unable to connect to database : SQLSTATE[HY000] [2002] No such file or directory | {"context":{"default":{"back_trace":{"file":"/usr/share/centreon/www/class/centreonDB.class.php","line":934,"class":null,"function":null},"request_infos":{"url":"/centreon/widgets/service-monitoring/src/index.php?widgetId=12&page=0","http_method":"GET","server":"x.x.x.x","referrer":"http://10.27.69.90/centreon/widgets/service-monitoring/index.php?widgetId=12&customViewId=3"}},"exception":{"exception_type":"PDOException","file":"/usr/share/centreon/www/class/centreonDB.class.php","line":147,"code":2002,"message":"SQLSTATE[HY000] [2002] No such file or directory","previous":null},"custom":{"db_name":"centreon","pdo_error_infos":["HY000",2002,"No such file or directory"],"pdo_error_code":2002,"dsn_mysql":"mysql:dbname=centreon;host=localhost;port=3306"}}}All services work, all connexion too.Does anyone had an idea ?Thanks !
Hello i am on 24.10.4 , i understood new version of centreon arrived someone can confirm ? Laurent
Hello,I'm trying to setup a Centreon infrastructure with a Central server and a Remote one.I’m using these versions:Centreon version 24.10 Running on Debian 12 Remote databasesI'm following the documentation.At the last step from Attach a remote server to a central server - when running:systemctl restart cbd centengineThe processes are restarted on the remote server, the web UI shows the remote as running (green),BUT the central server is set to "not running" (red) at the same time.The processes are still running on the Central server. When restarting the services on the Central serveur, the status is back to "running" (green).I haven't seen anything relevant in the logs to explain this.I can see these queries being run on the mysql server:2025-02-08T19:06:36.349406Z 205 Execute INSERT INTO instances (engine,running,name,pid,instance_id,end_time,start_time,version) VALUES('Centreon Engine',0,'Central',31412,1,1739041596,1739039104,'24.10.3') ON DUPLICATE KEY UPDATE engine='Ce
As mentioned, I got this error while trying to do step 4 of the server instructions (step 3.5 in the official documentation: Add a MariaDB table partition. This step is mandatory. Your Centreon server will not work if this isn't done.).I can connect to the web console, but I see a database issue/poller not running:
I was testing use cases on my centreon instance 23.10 with some hosts in a host group, then i wanted to provide custom view for monitoring purposes.I had no issue preparing those dashboards, but when i moved from 22.10 to 23.10, i realized that if a user isn’t configured as Admin, it cannot use the hostgroup widget, it stays empty.It doesn’t seem to be an ACL issue as the user can see the data in the resource status view and can even use the host monitoring widget. I’m unaware of what could be causing such issue.I saw there was issues with the filtering process as well on version 23.10 of Centreon, but i’m unsure if that’s related, so i’m opening an issue here.
Hello,I have received below error as i am upgrading my poller from 23.10 to 24.04.Error: Transaction test error: file /usr/1ib64/1ibmariadb.so.3 from install of mariabd-connector-c-3.1.11-2.e18x86 64 conflicts with file from package MariaDB-shared-10.5.16-1.e17.centos.x86_64 What should be done. Should i remove the package MariaDB-shared-10.5.16-1.e17.centos.x86_64?
Bonjour,Nous avons réussi à mettre en place l’authentification avec OpenID sur Centreon cependant nous souhaitons utiliser les fonctions de role mapping et de group mapping.Nous avons 4 différents rôles dans Ping Federate mais je crois que l’interprétation de la réponse de Ping Federate ne se passe pas bien lorsqu’on regarde les logs en mode debug : [2024-06-04T16:33:32+0200] [ERROR] [Core\Security\ProviderConfiguration\Domain\SecurityAccess\RolesMapping:152]: Configured attribute value not found in roles mapping configuration {"configured_authorized_values":["ADMINISTRATEURS","ADMINISTRATION","CONSULTATION","SUPERVISION"],"provider_conditions":["ADMINISTRATEURS|SUPERVISION"]}[2024-06-04T16:33:32+0200] [ERROR] [Core\Security\Authentication\Application\UseCase\Login\Login:139]: An error occured while matching your ACL conditions {"trace":"Core\\Security\\Authentication\\Domain\\Exception\\AclConditionsException: Role mapping conditions do not match in ….Je crois que la structure de la r
We wish to inform all users that BBDO2 will be officially deprecated with the 25.10 release of Centreon. This change is part of our ongoing effort to enhance the platform’s performance, security, and compatibility with modern infrastructure requirements. What is BBDO? BBDO, for Binary Broker for Data Operations, is a core protocol for exchanging monitoring data between a Centreon central server and pollers/remote servers. Why is BBDO2 Being Deprecated? With Broker 22.04.0, we have introduced a new version of BBDO based on Google Protobuf 3.The new protocol remains compatible with the previous one, but introduces new events.There are several key reasons for the depreciation of BBDO2:Performance improvements Flexibility: easier maintenance and enhancements To enable Broker-managed configuration & differential configuration export, which are using Protobuf messages (reduced network footprint for configuration updates).What This Means for You For most of our customers, BBDO3 is aread
I was alerted to low diskspace on my Centreon 24.10 server and the space was mostly being used by the database. On further investigation I saw that the partitioning had stopped 23/11/2024 with the pmax being the largest.Partitioning Properties Partition name Creation time Number of entries Data size Index size Total size pmax November 13, 2024 4:00:02 AM 209236541 8307 MB 3577.98 MB 11884.98 MB p20241123 November 13, 2024 4:00:02 AM 2035010 81.61 MB 53.61 MB 135.22 MB p20241122 November 13, 2024 4:00:02 AM 2104288 83.61 MB 54.64 MB 138.25 MB p20241121 November 13, 2024 4:00:02 AM 1952270 77.61 MB 51.59 MB 129.2 MB When I try to run “/usr/bin/php /usr/share/centreon/cron/centreon-partitioning.php” I receive:[root@LINFPV003 a-fv]# su - centreon -c '/usr/bin/php /usr/share/centreon/cron/centreon-partitioning.php'[Mon, 31 Mar 25 08:19:
Hello, we have migrated Centreon 21.04.11 on CentOS 7 to Centreon 24.10.3 on Debian 12, and we are facing the following issue. The only watchdog.json file we see is for the broker configuration; we don't see anything related to VMware. Can you help us? BR
Bonjour Nous constatons une différence de résultat entre la plage de statut des services qui va être supprimé et la page statut des ressources qui va la remplacer prochainement Notre architecture de serveurs :4200 hotes 92000 services V23.10 Centreon bientot en V24.10 central dedié , une bdd dedié , un MBI dedié , un Map dedié 200 collaborateurs journaliers connecté à Centreon 30% de nos sondes sont des sondes Custom a base de script Voici notre probleme :Sur la nouvelle page statut des ressources , nous ne trouvons pas les même informations que sur l'ancienne page statut des services qui nous semble plus correspond a la realité en fait je fais une recherche sur la page deprecié des services non traité+inconnu : le resultat est le suivant Le resultat est bien le meme dans etat des services tout en haut et dans la liste Maintenant j'utilise la page des ressources et je fais la meme recherche sondes services non traitées + inconnu resultat : il me donne 96 services qui ne correspondent p
Bonjour, ayant refait mon Centreon de zéro, j’ai un soucis sur les url d’actions.En effet, ayant quelques centaines d’hôtes. Je voulais savoir comment générer pour chaque hôte une URL d’action en fonction de son adresse IP ? merci
Hello,I configured multiple services check with an interval of 1 minute. The performance data are available but their representations in the graphs are still with a 5 minutes interval.Is it possible to do such a thing?Is it possible to parameter graph to display data under 1 minute?
Bonjour, J’ai configuré postfix sur ma debian 12 et le test mail fonctionne, mais je n’ai pas d’alerte sous centreon pourtant les notifications semblent bien activées quelqu’un à déjà rencontré le problème ? Merci pour vos réponses.
Bonjour à tous,J’aimerais avoir votre aide concernant la supervision des disques sur Centreon 24.10.5 avec AlmaLinux 9. Actuellement, les informations sur l’utilisation des disques sont affichées en pourcentage, mais j’aimerais savoir s’il est possible de convertir ces valeurs en Giga Octet (Go) pour une lecture plus claire et une meilleure analyse.L’idée serait de pouvoir superviser directement la capacité utilisée en Go plutôt qu’en pourcentage, afin de mieux évaluer l’état des disques et anticiper les risques de saturation. Si vous avez déjà mis en place ce type de configuration ou si vous connaissez une méthode pour effectuer cette conversion dans Centreon, je serais vraiment preneur de vos conseils !Merci d’avance pour votre aide et vos retours. 😊Lenny Vaz
Hello,I want to use NET-SNMP-EXTEND-MIB to monitor systemctl services.I added these two lines in the snmpd configuration:extend 1 /usr/bin/systemctl is-active centengine.serviceextend 2 /usr/bin/systemctl is-active gorgoned.service When I query the MIB with snmpwalk, I get this:# snmpwalk -v 2c 127.0.0.1 -c public .1.3.6.1.4.1.8072.1.3.2NET-SNMP-EXTEND-MIB::nsExtendNumEntries.0 = INTEGER: 2NET-SNMP-EXTEND-MIB::nsExtendCommand."1" = STRING: /usr/bin/systemctlNET-SNMP-EXTEND-MIB::nsExtendCommand."2" = STRING: /usr/bin/systemctlNET-SNMP-EXTEND-MIB::nsExtendArgs."1" = STRING: is-active centengine.serviceNET-SNMP-EXTEND-MIB::nsExtendArgs."2" = STRING: is-active gorgoned.serviceNET-SNMP-EXTEND-MIB::nsExtendInput."1" = STRING:NET-SNMP-EXTEND-MIB::nsExtendInput."2" = STRING:NET-SNMP-EXTEND-MIB::nsExtendCacheTime."1" = INTEGER: 5NET-SNMP-EXTEND-MIB::nsExtendCacheTime."2" = INTEGER: 5NET-SNMP-EXTEND-MIB::nsExtendExecType."1" = INTEGER: exec(1)NET-SNMP-EXTEND-MIB::nsExtendExecType."2" = INTEGER:
Bonjour, Depuis la présentation des collections HTTP au dernier Centreon Summit, je cherche à réaliser une supervision de l’espace disque utilisé sur un Radware Alteon par son API.Existe-t-il une documentation exhaustive des différentes clés (paramètres) et fonctions qu’on peut utiliser dans les collections en général (HTTP, SNMP et SQL) ?J’ai vu par exemple qu’il faut utiliser le paramètre “insecure=1” pour ne pas vérifier le certificat. J’imagine que ce paramètre correspond à l’option `--insecure` du mode “response” (`--mode=response`) ? Est-ce que si je déclare un paramètre “proxyurl=http://IP_PROXY:PORT_PROXY” comme je le fais avec le mode=response (`--proxyurl=’http://IP_PROXY:PORT_PROXY’`), cela fonctionnerai ?De même pour les différentes fonctions utilisables. J’en relève au moins deux : count et assign. En existe-t-il d’autre ?
Hello everyone, I recently viewed that the template check “OS-Linux-Disk-Global-SNMP-custom” has a problem and I don’t know how to resolve it. The server shows the free disk storage but differs from the centreon check and the server (df command). I’m aware that the real number is what is shown in the server site, but why is centreon showing another numbers?ServerIn my server i can see the /data disk usage:$ df -h /data/dev/mapper/01--vg-data 4,4T 3,8T 476G 89% /data$ df -H /data/dev/mapper/01--vg-data 4,9T 4,1T 511G 89% /data$ df /data/dev/mapper/01--vg-data 4695587440 3996106512 498103636 89% /data Centreonbut when I use the check i see this in my /data: I also used the same script as the service and encounters the same problem: $ /usr/lib/centreon/plugins//centreon_linux_snmp.pl --plugin=os::linux::snmp::plugin --mode=storage --hostname=$server --snmp-version='2c' --snmp-community='public' --storage='\/data|\/srv$|\/tmp$|\/var$|\/boot$|\/$' --name --regexp --displ
Hello everyone,After migration, when consulting the event log, these errors appear.# tail -f /var/log/centreon-gorgone/gorgoned.log2025-03-21 08:00:52 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '503'] [message: 'Service Unavailable']2025-03-21 08:01:52 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '503'] [message: 'Service Unavailable']2025-03-21 08:02:52 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '503'] [message: 'Service Unavailable']2025-03-21 08:03:52 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '503'] [message: 'Service Unavailable']2025-03-21 08:04:52 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '503'] [message: 'Service Unavailable']2025-03-21 08:05:52 - ERROR - [autodiscovery] -class- host discovery
Hello.Is it possible to retain acknowledges or downtimes applied to services or hosts when changing a host to another poller?I’m in the process of moving hosts from my old CentOS pollers to new Oracle Linux pollers and this is lost after changing the poller.I’m moving in small batches to check possible problems with the checks in the new pollers before moving the whole lot to the new one.RegardsEnrique
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.