Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello All,First thank you for help.I’m new on Centreon so i still confuse something about monitoring on Rest API v1.I have a website (need login) to monitoring stat of service:ex:<overAllStatus><status>RUNNING</status></overAllStatus><authentication><authBrokerStatus><reason>Reachable</reason><status>RUNNING</status>i have check and seem no plugin for my appliance.So how can i monitoring this server ? i can’t found any template related to it.Thank you for help.
Dear community.We are looking for sensor connected with Centreon to be notified when a site experiences a power outage:Is it possible? What brands of products are compatible?Thank you.Regards.Sebastien Moriamez-Tison
Bonjour Je n’arrive pas à résoudre le/les problèmes de mise à jour avec DNF Almalinux 9 et centreon 23.04 Avec le temps ca s’accumule car de nouvelles mises à jour de paquets sont proposées Je ne trouve pas de solution pour indiquer à DNF d’installer ou mettre à jour les dépendances. Message d’erreur : Problème 1: installation impossible du meilleur candidat pour le paquet centreon-connector-perl-23.04.0-1.el9.x86_64 - rien de fournit libperl.so.5.26()(64bit) rendu nécessaire par centreon-connector-perl-23.04.2-1.el8.x86_64 Problème 2: le paquet centreon-connector-23.04.2-1.el8.x86_64 nécessite centreon-connector-perl = 23.04.2-1.el8, mais aucun fournisseur ne peut être installé - installation impossible du meilleur candidat pour le paquet centreon-connector-23.04.0-1.el9.x86_64 - rien de fournit libperl.so.5.26()(64bit) rendu nécessaire par centreon-connector-perl-23.04.2-1.el8.x86_64 Problème 3: le paquet centreon-connector-perl-23.04.0-1.el9.x86_64 nécessite centreon-clib = 23.0
Hello, is there any change to create following at centreon ? monitor service on multiple hosts Notify only when service on all hosts are down.My problem is that i have to monitor service which is running on one or second host, but not simultaneously. what is best way to achieve it. thank in advance
Hello, Is it possible to get a bit of help to integrate THK Security (aka Siqura) cameras ?I identified a couple of useful information after installing their MIBs (free to download but need to register on their website) Temperature:OPTC-DEVICE-MIB::optcActualTemperature.1.1 = INTEGER: 57 Degrees CelsiusOPTC-DEVICE-MIB::optcPeakTemperature.1.1 = INTEGER: 60 Degrees CelsiusOPTC-DEVICE-MIB::optcTemperatureAlarmLevel.1.1 = INTEGER: 75 Degrees CelsiusOPTC-DEVICE-MIB::optcTemperatureAlarm.1.1 = INTEGER: false(2) Network bandwidth:OPTC-DEVICE-MIB::optcTotalTxBitrate.1.1 = Gauge32: 4487 bit/sOPTC-DEVICE-MIB::optcTotalRxBitrate.1.1 = Gauge32: 97 bit/s A bunch of alarms:OPTC-DEVICE-MIB::optcTemperatureAlarm.1.1 = INTEGER: false(2)OPTC-DEVICE-MIB::optcPowerSupplyAlarm.0 = INTEGER: 0OPTC-STATUS-MIB::optcStreamDownAlarm.1.1 = INTEGER: false(2)OPTC-STATUS-MIB::optcStreamDownAlarm.1.2 = INTEGER: false(2)OPTC-STATUS-MIB::optcSignalLostAlarm.1.1 = INTEGER: false(2)OPTC-STATUS-MIB::optcFormatAlarm.1.1 =
Hello, I just updated the Centreon central on Almalinux 8 with the latest version. (via https://docs.centreon.com/fr/docs/update/update-centreon-platform/) My central won't start, yet I did systemctl daemon-reload and restarted all services.
Hello guys I have a centreon with centreon engine 1.8.1 and the central poller on the localhost is stopped working after the reboot I have check and restarted all the services and its running fine database is running fine please help me with problem
Hello and good morning!I´d like to use the exagrid plugin to display the landing and retention usage.. that´s working fine - but I need to define the treshholds now.How can I do that? It´s not working with/usr/lib/centreon/plugins//centreon_exagrid_snmp.pl --plugin=storage::exagrid::snmp::plugin --mode=server-usage --hostname=172.16.253.1 --snmp-version='2c' --snmp-community='public' --warning-status='%{status} =~ /warning/i' --critical-status='%{status} =~ /error/i' --warning-retention-usage='85' --critical-retention-usage='95' --warning-landing-usage='85' --critical-landing-usage='95'or with %-Values...
Good evening,I have a strange problem, in the event log I don't see all events. I can see Aknowledge, Hard, Soft Events from Services and Hosts.But in the event log no noftifications messages appear.Also in the timeline I can't find any notifications.What can be the reason for this?Many greetingsMartin
Hello,Since the installation of a new remote poller, We have the error:Status information(Execute command failed)Please, see it in the screenshot. When I execute the check command, we have an error:The file check_centreon_nrpe does not exist.can someone please help me?
Hello community, I am new in centreon so quickly get stack at version upgrade from 20.04 to 21.10My error is: Database updates not active, pollers not running, last update in yellow:Somehow I found as well in the logs that the connection to SQL is failed:2022-05-02 11:49:13|0|0|0|[local] [127.0.0.1] Authentication failed for 'admin' I have a little idea about forcing the connection to sql but the centreon user is “centreon” normally for database.Please help as my research was unsuccessfully. Regards,Eugene
Hi,On my Staging environmentInstalled: 22.04.7 up-to-dateUpgrad to: 22.10.1 https://docs.centreon.com/docs/upgrade/upgrade-from-22-04/Point:yum update centreon\* php-pecl-gnupg Error:--> Finished Dependency ResolutionError: Package: centreon-web-22.10.1-4.el7.centos.noarch (centreon-stable-noarch) Requires: php-common >= 8.1 Installed: php-common-8.0.12-1.el7.remi.x86_64 (@anaconda) php-common = 8.0.12-1.el7.remi Available: php-common-5.4.16-48.el7.x86_64 (base) php-common = 5.4.16-48.el7Error: Package: centreon-web-22.10.1-4.el7.centos.noarch (centreon-stable-noarch) Requires: php-pecl-protobufError: Package: centreon-web-22.10.1-4.el7.centos.noarch (centreon-stable-noarch) Requires: php-pecl-grpcError: Package: centreon-web-22.10.1-4.el7.centos.noarch (centreon-stable-noarch) Requires: brotliError: Package: php-sourceguardian-loader-8.1-1.el7.centos.x86_64 (centreon-stable) Require
Hello,I need to make a SQL request in Centreon. But the SQL request should be take data to external database, thats means, Centreon haven’t this database. I created a HOST with my server data, and a service with SQL Request. This image contain the values of service.And the next picture is the error.Well, how can I make this action?
Hello,I’m trying de install a fresh centreon poller in redhat9 using this : https://docs.centreon.com/docs/installation/installation-of-a-poller/using-packages/it’s working but when i tried to install centreon plugin’s there a missing dependency :dnf install centreon-plugin-\*=> - rien de fournit perl(JSON::Path) rendu nécessaire par centreon-plugin-Applications-Protocol-Jmx-20230810-100132.el9.noarchsomeone has encounter this problem ? Regards
Hi everyone, I’m setting up Centreon to monitor different infrastructures and I would like to create 2 different services to check the HDD on Windows servers (using SNMP). The idea would be to adjust the checks intervals and values depending on which HDD we are talking (system HDD or “storage” HDD) I already created a service model checking only C: but I want to create an other service model that will check all HDD except C:.Can anyone help me find the value I should use after DISKNAME ? I was thinking about what could be the translation of “check all hard drives above the letter C” or “check all hard drives except C”. I am pretty new to Centreon and I have no knowledge of this kind of value formulae. Thanks a lot :)
Hello,I have experienced an issue with my centreon since a week.The Connection-Time does not work because the user centreon-engine has access denied from localhost. I have searched for a solution on The Watch’s blogs, and I still have not found either what could it be or how to solve it. Also, I would like to know if this issue could result in the fact that if I make a modification in a host or a service, the centreon does not apply it. May someone help me please ?
Hello, my poller can't start on my central server. I have configured the access with the user centreon-gorgone in ssh. I have followed this procedure well: https://docs.centreon.com/fr/docs/monitoring/monitoring-servers/add-a-poller-to-configuration/I see no errors in the logs. Can you help me to understand my error? Central :log central : 2023-03-25 15:30:46 - INFO - [core] Initialize server keys2023-03-25 15:30:46 - INFO - [core] Private key file '/var/lib/centreon-gorgone/.keys/rsakey.priv.pem' loaded2023-03-25 15:30:46 - INFO - [core] Public key file '/var/lib/centreon-gorgone/.keys/rsakey.pub.pem' loaded2023-03-25 15:30:46 - INFO - [core] update schema 22.04.0 -> 22.04.02023-03-25 15:30:46 - INFO - [core] Module 'httpserver' is loading2023-03-25 15:30:46 - INFO - [core] Module 'httpserver' is loaded2023-03-25 15:30:46 - INFO - [core] Module 'action' is loading2023-03-25 15:30:46 - INFO - [core] Module 'action' is loaded2023-03-25 15:30:46 - INFO - [core] Module 'cron' is loadi
Hello,On my Centreon deployment the inheritance of contacts and contact groups defined in host definitions no longer works on services connected to the host. Now we get messages only when the host goes down or up and no longer receive messages for the services associated with that host.I'm not sure when this problem started appearing. I’ve patched Centreon to the latest 22.10.9 version and the problem persists. A workaround is setting “Inherit only contacts/contacts group from host“ to “yes” but this would require me to set that bit for every service associated with the host and can't be configured in the service template.“Contacts & Contact groups method calculation” is still set to “Vertical Inheritance Only” and changing options does not resolve the issue.Any help would be much appreciated!
Hi fellow community members,I recently installed a Centreon 23.04 server on a Debian 11 host in order to monitor a specific appliance.I wrote some plugins (in Python) to monitor the appliance metrics, created related commands, service templates and host templates.Then I created a bunch of yaml configuration files (for templates, commands...) with the aim to make a plugin pack of it.So I have specifics python plugins, related yaml files for templates and commands, all packaged in a zip file.Is it the good way to make a plugin pack ? I can’t manage to find a concrete and clear documentation about the subject in the Centreon documentation.If not, am I far from my goal ?Other concern how to deploy this pack on others Centreon instances ? On the extension manager page, I don’t see any upload interface or something like that. Am I missing something ? Thanks in advance.Sebastien
Hello,using centreon_ubiquiti_airfiber_snmp.pl --plugin=network::ubiquiti::airfiber::snmp::plugin --mode list-radios will return UNKNOWN: Need to specify OIDsAccording to tcpdump it sends snmp request:GetNextRequest(33) .1.3.6.1.4.1.41112.1.3.1.1.14and gets response:GetResponse(35) .1.3.6.1.4.1.41112.1.4.1.1.1.1=5and that is all. Tested on multiple devices with multiple firmwares with the same result. What is wrong?
Hi, I search for a good “Plugin” for query Rest Api query for Centreon. with Rest Api Authentification Bearer Token for example with “curl” work good curl -X GET "https://server01/api/datacenter/cluster/clusters" -H "accept: application/json" -H "authorization: Basic b3BzOm9wcwL9" -H "UM-CSRF-Token: ab657dd3-42be-4r3d-f60a-2de3f5521” Thanks
How to run commands in the linux host and get the output
HelloIs it possible to put a remote server after an other one ?what I want to have is my central server in my private network, a remote server in my DMZ to communicate with my customers network, and a remote server in my customers network.I need a remote server on my customer network in order to have an IHM on his network to view his own infrastructure’s monitoring. Or perhaps a poller can send data to 2 remote servers with one that have no idea of the poller config ?Thanks for any idea
Guys i just installed Centreon for testing on my lab, for whatever reason i was using the incorrect password for the user admin in the web access and now the user is bloqued.Do you have any advise on how to unlock the user, i have access to the centos root without any problems. Thanks
Hi,I trying to install centreon MBI on RHEL9 but there 2 problems :it’s seems that not el9 available on the yum’s repo it’s seems that MBI is not available in Centreon 23.04 on the yum’s repoSomeone can confirm that MBI is not compatible for RHEL9 on Centreon 23.04 ? Regards
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.