Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,Do you know if it is possible to monitor the number of hosts and services monitored by Centreon?Several times while modifying services I made a mistake and services were deleted, if I'm not careful I might not even realize it.I would therefore like to have a graph on this information and be alerted below a certain threshold.Thanks
Bonjour,J’ai ajouté un downtime à 3 machines qui sont sorties du parc pour arrêter les check (et en espérant qu’elles ne seraient plus en “critical” (j’aime quand tout est vert 😁).J’ai donc ajouté des downtime jusqu’en 2200, j’ai vu large (trop), mais après avoir appliqué la conf j’ai mon poller not active et databas updates not active (je n’ai qu’un central).Dans /var/log/centreon-broker/central-broker-master.log j’ai :[sql] [error] mysql_connection: could not store downtime: Out of range value for column 'end_time' at row 1En regardant ici https://docs.centreon.com/fr/docs/alerts-notifications/downtimes/ je me suis dit qu’il suffisait que je supprime les downtime mais je ne trouve pas le “Rendez-vous dans le menu Monitoring > Downtimes > Downtimes”Soit je suis cherche mal, ce qui n’est pas exclu, soit je n’ai pas ce menu en 21.04.3Une âme charitable aurait une autre solution ? Directement en bdd ?[EDIT]Voici le même fichier de log complet après un reload :[2023-03-14 19:43:3
Hi!First time posting here, It’s been some time since we had working graphs on Centreon and I’m trying to see if I can make them work again. Here is a summary of the situation : It’s been like this for 6 months. This morning I updated from 22.04 to 22.10 but it’s the exact same thing: I either have “ No data available for this period ” or graphs but without any data on them. I saw other posts from other users and tried the solutions (like adding an IPv4 output named centreon-broker-rrd, see), but nothing seems to work. I appreciate any help :) Thanks!
I’m running the default linux snmp templace but I’m only getting the used performance data, I’m missing the total disk size. EDIT: I’m trying to include the command and output, but as soon as I do my post gets rejected with a 403 error.
Hello,We currently monitor SQL Server without any encryption in the communication (all is working fine).We would like to activate encryption for all communications with our SQL Server (option Force Encryption = Yes), but we don't how to accept this encryption in Centreon.Could you please help us ?
Hi,I’ve updated my test server from 22.04.7 to 22.10.1During php-pecl-gnupg update, I have several warning like this: Running transaction Updating : php-common-8.1.12-1.el7.remi.x86_64 1/30 Updating : php-xml-8.1.12-1.el7.remi.x86_64 2/30 Updating : php-pdo-8.1.12-1.el7.remi.x86_64 3/30 Updating : php-mysqlnd-8.1.12-1.el7.remi.x86_64
How do I add custom icons in Centreon? I’ve placed a PNG file in the /usr/share/centreon/www/img/media/ppm/ folder, but it’s not showing in the drop down menu in the “Host extended infos” page.
Hello,I created a service to Monitor the E drive on a few of my Windows computers. There are 3 of them and 2 work fine but the 3rd gives an error. Any Idea why?
Hello,We have three different Windows domains. We have a user to monitor infraestructure, let’s say ‘Monitor’, defined in all three domains. Password for this user is different in every domain.According to this article (https://docs.centreon.com/pp/integrations/plugin-packs/getting-started/how-to-guides/windows-winrm-wsman-tutorial/#configure-kerberos-on-the-centreon-server), when configuring pollers you create a file called Monitor@keytab ‘to allow reconnection without a password for the reinitialization part’.However, If I repeat the process for every domain, I will rewrite the same file three times. How do I have to do when configuring three different domains with the same user? Do I have to use different users? Can I follow the configuration process you suggest using @USERNAME@+@DOMAINNAME@ when you tell to use @USERNAME@? Will the ‘realm’ command work fine repeating it for the three domains? I’m not sure about if all commands will work properly.Can you tell me how to do it?Thanks
Good afternoon all,I would like to thanks for all informations which are in this forum. It’s very complete but maybe to advanced for me.I’have a little problem to install centreon. My architecture is very simple :one machine with debian 11 and centreon central one machine to show and try to test centreon.However, I have a problem. my centreon.service is “exited”.I’m going to the logs and I have find this error :When I have read the line 45 or 142 on the file notified, i don’t understand why this variable is not ok.I have search to obtain information and understand the problem but internet is empty on this subject…Can you help me or explain the problem please ?thank you for all Laurent the big newbie
HiI use Centreon IT-100 Edition, 22.10.5, on a standalone Linux Debian 11.I would like to be able to use the stream connector to send my alerts in Opsgenie.So I followed the documentation here: https://docs.centreon.com/docs/21.10/integrations/event-management/sc-opsgenie/ but nothing is sent to Opsgenie.I double checked my configuration: parameter of the connector, api key value, permission in Opsgenie, access to api url, etc. but all is good.I tried to execute the lua script and no output appeared (normal) so I think all is good for Lua in my system.Here are the lua packages installed:~$ apt list lua* --installedListing... Donelua-curl/stable,now 0.3.0-9.2 amd64 [installed]lua-socket/stable,now 3.0~rc1+git+ac3201d-4 amd64 [installed]lua5.1/stable,now 5.1.5-8.1+b3 amd64 [installed]Then I tried to elevate the logging level to debug for [core] and [lua] in central-broker-master configuration and I saw these messages (filtered) :~$ sudo systemctl restart cbd~$ tail -f /var/log/centreon-b
Hi,I often have a critical alert for the Memory service of my centreon -central.Any idea to relieve the RAM memory?Service Status CRITICAL Status information CRITICAL: Ram Total: 7.45 GB, Used (-buffers/cache): 7.08 GB (95.03%), Buffer: 3.40 MB, Cached: 118.80 MB, Shared: 14.85 MB Any idea to relieve the RAM memory?THANKS ;-)
Hello Team,Since my upgrade to version 22.10.6 I’m not able to acknowledge some alertes….Someone can help me.Regards,
Hi all,We would like to add a 4th poller, we have follow the procedure to add them, poller work well but central can’t see them.I open a ticket to the support , after 2 webex we are in the same issue.Did you have see the same situation ?(we use an external MariaDB 10.6) Thanks
Hi,We have here Centreon 22.04.We use the clapi binary on our Central Server to manipulate Centreon objects: particulary to import /build hosts, hosttempletes, servicestemplates ...etcThe binary is provided by the package "centreon-web-22.04.7-5.el7.centos.noarch"EX:/usr/share/centreon/bin/centreon -u admin -p XXX -o HG -a show/usr/share/centreon/bin/centreon -u admin -p XXX -i my_file.txt # THIS WILL IMPORT THE CONTENT OF THE FILE Now we need to run this but from another linux server (Not on the Central), be I wonder how it is possible : ? Install the binary but how to specify where is the Centreon environment (database) to modify.In other words : we need to run imports/creation of centreon objects remotely.Has anyone already done this before ?I know ‘centctl’ : but is from community and not supported by Centreon …Thanks a lot !
once i play the OS-LINUX-Cpu-SNMP-custom check-command i got this messagebut when i play this command on backend they conplains that the argument --host is missing, but i don’t say how do i parse it on front end/usr/lib/centreon/plugins/centreon_linux_snmp.pl --plugin=os::linux::snmp::plugin --mode=cpu --help Output perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = (unset), LC_ALL = (unset), LANG = "pt_BR.UTF-8" are supported and installed on your system. perl: warning: Falling back to the standard locale ("C").
We want to monitor the virtual fabric on our brocade san switchsHas anyone ever encountered this type of problem and found a solution?
Hello, I’m configuring mail notification for my Centreon server, but I can’t receive mail after configuring Postfix. I tried few parameters from different tutorials but it still doesn’t work. Logs : Feb 13 15:53:18 xxx postfix/qmgr[584413]: ED80F64CD1: from=<centreon-engine@xxx.xxx.xxx>, size=671, nrcpt=1 (queue active)Feb 13 15:53:18 xxx postfix/qmgr[584413]: E905E64DF0: from=<centreon-engine@xxx.xxx.xxx>, size=731, nrcpt=1 (queue active)Feb 13 15:53:18 xxx postfix/error[597488]: ED80F64CD1: to=<xxx@xxx.xxx>, relay=none, delay=719, delays=719/0/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to smtp.xxx.xxx[xxx.xxx.xxx.xxx]:25: Connection refused)Feb 13 15:53:18 xxx postfix/qmgr[584413]: E722B64DCE: from=<centreon-engine@xxx.xxx.xxx>, size=671, nrcpt=1 (queue active)Feb 13 15:53:18 xxx postfix/error[597695]: E905E64DF0: to=<xxx@xxx.xxx>, relay=none, delay=5939, delays=5939/0/0/0, dsn=4.4.1, status=deferred (delivery temporarily su
After a fresh install with packages on Debian 11.I read all about it and even I wrote a post with some errors.In /var/log/centreon-broker/central-broker-master.log there a some errors The error have sense cause cbd is listening on 0.0.0.0 Since I tried this before. I used the IP (13.0.2.252) of the instance into the form during https://docs.centreon.com/docs/installation/web-and-post-installation/#web-installationcentreon/config.d/10-database.yaml, centreon/centreon.conf.php, centreon/conf.pm have 13.0.2.252.More errors...central-broker-master.log:[2023-03-06T15:24:58.072+00:00] [core] [error] failover: global error: failover: 'centreon-broker-rrd' cannot connect endpoint.central-rrd-master.log:[2023-03-06T15:29:37.240+00:00] [bbdo] [error] BBDO: invalid protocol header, aborting connection: waiting for message of type 'version_response' but nothing receivedcentral-rrd-master.log:[2023-03-06T15:29:37.240+00:00] [tcp] [error] Error while reading on socket: End of filecentral-rrd-master
Hello, Is it possible to download the Centreon documentation (https://docs.centreon.com/docs/22.04/XXXX) in .pdf or .html to read locally ? Thank you.
Hello the community,Nice to meet you. I am testing Centreon 22.10.5 using remote pollers.Is there any conditions for changing the centreon-engine password? Could I change it with no risk?
Hello,I am testing the new version of Centreon Map (22.10), the problem is that when I click on a map to view it, sometimes it works and displays the map, sometimes it doesn't show anything for a second and returns to the maps list page, so I have to click on the map two or three times to be able to display it.Here are some photos:if I want to display the map named “myMap”, it will display like this for a secondthen it’s rollback to maps list pageI have to repeat the process two or three times to be able to display myMap Thank you for your help.
Good morning, I am monitoring several Windows services with "centreon_windows_snmp.pl". It works fine with the following argument and service name, for example: --service='dcsx'. My question is: why does it show services in critical state if they are running? I have tested with the "Print Spooler" service and it works fine. I have also tested with the DataCore Executive service and even though it is running, it appears as critical. All of this with the same configuration and host. King regards.
Hello community ! I’ve recently encountered a problem while trying to install the centreon-plugin-Operatingsystems-Linux-Local.noarch component for Linux NRPE3 plugin supervision on an Oracle Linux end-server, using Ansible automation. Here is a fragment of my Ansible playbook code (I use yum_repository as dnf_repository is not yet available in Ansible):- name: Add Yum repository yum_repository: name: Centreon baseurl: https://yum.centreon.com/standard/22.10/el8/stable/x86_64 - name: Install requirements dnf: name: “{{ item }}” state: latest with_items: - centreon-nrpe3-daemon.x86_64 - centreon-plugin-Operatingsystems-Linux-Local.noarch While launching the above playbook i got the following error related to the installation of the second component:Depsolve Error occurred:Problem: cannot install the best candidate for the job - nothing provides perl(JSON::XS) needed by centreon-plugin-Operatingsystems-Linux-Local-20230215-164619.el8.noarch I did some research
Hello,I'm installing centreon 21.04 and I'm stuck at step 2 (step 2)error message log/php-fpm/centreon-error.logthe installation is on a shared serverError log centreon.log PHP Fatal error: Uncaught PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'centreon.informations' doesn't exist in /usr/share/centreon/www/class/centreonDB.class.php:2Stack trace:#0 /usr/share/centreon/www/install/step_upgrade/step3.php(52): CentreonDB->query('SELECT `value` ...')#1 {main} thrown in /usr/share/centreon/www/class/centreonDB.class.php on lineThanks in advance
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.