Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
I would like to see the SLA availability level for each host in my host group over a period of one year. Which metric and widget on the dashboards would allow me to find this out?Thank you in advance!
Bonjour à tous lorsque je veux affiché les graphs des données reçu j’ai ce message d’erreurs sur debian 12
Hello, since the rotation GPG key (i suppose) the rpm-standards packages for centreon are unavailable on artifactory.https://packages.centreon.com/ui/native/rpm-standard/I see that they are possibly still on the rpm-test-standardWe need those packages to be back available as soon as possible. If this intended, please tell me what is the expected operation to access those packages again
Hello,I try to follow this documentation to install NRPE + centreon plugin on my server:https://docs.centreon.com/fr/pp/integrations/plugin-packs/procedures/operatingsystems-linux-nrpe4/i have some problem :On the requirements part, the nrpe4 package is not mention to install on the server, is it normal ? (if i compare on Debian requirements install, there the nrpe4 package) when i try to install centreon plugin package “centreon-plugin-Operatingsystems-Linux-Local.noarch” there bad signature : Erreur : Erreur de la transaction de test : package perl-HTTP-ProxyPAC-0.31-2.el8.noarch does not verify: Entête DSA signature: BAD (package tag 267: invalid OpenPGP signature) package perl-Exporter-Tiny-1.006002-2.el8.noarch does not verify: Entête DSA signature: BAD (package tag 267: invalid OpenPGP signature) package perl-LV-0.006-2.el8.noarch does not verify: Entête DSA signature: BAD (package tag 267: invalid OpenPGP signature) package perl-Carp-Assert-0.22-1.el8.noarch does not v
Hello guys i’m trying to monitor a ubuntu 24.04 and i have some issues i had 5.38 perl version and had this problem when trying to dowload nrpe client apt -y install centreon-nrpe4-daemon centreon-plugin-operatingsystems-linux-local Les paquets suivants contiennent des dépendances non satisfaites : libcrypt-openssl-aes-perl : Dépend: perlapi-5.36.0 mais il n'est pas installableE: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ». and when i deleted perl 5.38 to switch on perl 5.36 i had this problem Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.Les paquets suivants contiennent des dépendances non satisfaites : centreon-plugin-operatingsystems-linux-local : Dépend: libcrypt-openssl-aes-perl mais ne sera pas installé Dépend: libpod-parser-perl mais ne sera pas installé Dépend: libnet-curl-perl mais ne sera pas installé
Hi,I’ve a problem to import custom MIBs on my centreon 25.10.1I try to import with Configuration → SNMP Traps → MIBsI add my Vendor name (eg. SICE) and load my .mib file, but I’ve this errorUse of uninitialized value in concatenation (.) or string at /usr/share/perl5/vendor_perl/centreon/common/db.pm line 204. Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/vendor_perl/centreon/common/db.pm line 204. Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/vendor_perl/centreon/common/db.pm line 212. 2025-12-05 08:57:47 - ERROR - MySQL error : cannot connect to database : Access denied for user 'apache'@'localhost' (using password: NO) (caller: centreon::script::centFillTrapDB:/usr/share/perl5/vendor_perl/centreon/script/centFillTrapDB.pm:771)Generate Traps configuration files from Monitoring Engine configuration form! I see there is error Access denied for user 'apache'@'localhost' how can I change this user?
Hi all,My version of Centreon is 25.10Any idea why its asking for my username/password when I try and use my copied autologin url:https://192.168.20.29/centreon/home/dashboards/library/3?autologin=1&useralias=autologin&token=cQSPFRHWEe When I use this link it works fine without asking for username/password:https://192.168.20.29/centreon?autologin=1&useralias=autologin&token=cQSPFRHWEebut then if doesn’t take me to my dashboard.Interesting if I use my first link after using this link it works fine.thanks for help.Steve.
Hi,During my migration from 22.10 to 23.04, I had some issues with host auto discovery.The following error is visible in the gorgone log[autodiscovery] -class- host discovery - cannot get host discovery jobs - request error [code: '404'] [message: 'No route found for "GET https://<centreon>/centreon/api/latest/auto-discovery/scheduling/jobs"']The API seams to be good because I am able to check the current version of the api:curl https://<url>/centreon/api/latest/platform/versions{"web":{"version":"23.04.0","major":"23","minor":"04","fix":"0"},"modules":{"centreon-pp-manager":{"version":"23.04.0","major":"23","minor":"04","fix":"0"},"centreon-license-manager":{"version":"23.04.0","major":"23","minor":"04","fix":"0"},"centreon-autodiscovery-server":{"version":"23.04.0","major":"23","minor":"04","fix":"0"}},"widgets":{"Service Monitoring":{"version":"23.04.0","major":"23","minor":"04","fix":"0"},"Grid-map":{"version":"23.04.0","major":"23","minor":"04","fix":"0"},"Global Healt
Hello,Is there a plugin HP MSA 2000 for a poller under DEBIAN ?https://docs.centreon.com/fr/pp/integrations/plugin-packs/procedures/hardware-storage-hp-msa2000-snmp/Thanks,
Hi,I would like to purchase the IT-Edition to be able to install plugins on my centreon. I recently updated to 25.10.I find the web page about licences a bit confusing. It says the free version can be used with up to 100 hosts, and the “IT Edition” is showed as “2.2€/host, 275€ for 125 hosts”.I already use centreon with the Free edition marked as “Up to 100 Hosts” but I already have 300+ hosts that are monitored. Is the “Up to 100 Hosts” limit based on the number of SUPERVIZED hosts or on the number of Centreon poolers? Does that mean that if I only want one Centreon machine (1 pooler) but with 300 supervized machines I can have a licence for 2.2€ per month? Thanks,
Is there any configuration to graph ping host performance data .All my are populated with perfdatas ,But i see no graph …Any idea ?
Hello,I updated multiple servers to Debian 12 and all Centreon 24.10.18. I got an issue with the HP MSA pluginUNKNOWN: Can't use an undefined value as a subroutine reference at /usr/lib/centreon/plugins//centreon_hp_msa2000.pl line 11214.orUNKNOWN: Can't use an undefined value as a subroutine reference at /usr/lib/centreon/plugins//centreon_hp_msa2000.pl line 11168.(It depend of the update). both are targeting the line : $func->($self);}sub load_components { my ($self, %options) = @_; foreach (@{$self->{components_module}}) { if (/$self->{option_results}->{component}/) { my $mod_name = $self->{components_path} . "::$_"; centreon::plugins::misc::mymodule_load( output => $self->{output}, module => $mod_name, error_msg => "Cannot load module '$mod_name'.") if ($self->{load_components} == 1); $self->{loaded} = 1; if ($self->{components_exec_load} == 1) { my $func = $mod_name->can('load'); $func->($self); } } }}An
Hello,I think you must separate the client support and server support in the Centreon ecosystem.As we don’t need the support for installing the server part of Centreon early on new distribution releasesWe need it as soon as possible for monitoring hosts. Because that is the goal on a monitoring solution.As today , 3 months after Debian 13 release and 6 month after the RedHat 10 release, we can’t monitor efficiently theses hosts.How can I say to customers that they will not be monitored because Centreon is unable to support majors OS at their release and event months after ?CMA is not ready for production (too young, features are missing, new tcp ports, new security mechanism, changing enterprise way to do are long path.), so we can't deploy it yet.You must ensure a period of transition when changing this type of components, by still providing the previous agents and the new one. Both on current OS releases.So we need to be able to do it with the current tools like NRPE4https://docs.ce
Hi, I’ve used an older version Centreon 2.4.1 (yeah really old! lol) and I never had this issue, but now on 25.10 I have the issue where when I delete a host it then deletes all the services linked to the host even the ones that are used by other hosts. Obviously this is massive issue and will lead to my staff accidentality deleting services when they delete the hosts. I don’t remember this being an issue in the older versions of Centreon.Is there a workaround for this? I don’t really want to use service groups / host groups as I don’t want hundreds of different host groups based on my services, I need it to be a bit more flexible.Is there a way to prevents the deletion of the hosts and only allows disabling? or a way to stop centreon deleting the services when the hosts are deleted.thanks in advance.steve.
Hi all,Just another questions, I get this results when I try and install the monitoring agent pack on my alma 9 central server:dnf install centreon-pack-operatingsystems-linux-centreon-monitoring-agentNo match for argument: centreon-pack-operatingsystems-linux-centreon-monitoring-agentError: Unable to find a match: centreon-pack-operatingsystems-linux-centreon-monitoring-agent Any ideas where I am going wrong?Its the Open Sourced edition version 25.10thanksSteve.
Hello,We started to use the REST APIv2, but we noticed that there is no delete operations for the commands term point (/configuration/commands)Is there a reason for that ? or it’s planned to be implemented ?
I am following the documentation: https://docs.centreon.com/pp/integrations/plugin-packs/procedures/operatingsystems-linux-nrpe4/ But when I try to install the connector on ALMA Linux 8.10 with the following command:dnf install centreon-pack-operatingsystems-linux-nrpe4 I get the following error:No match for argument: centreon-pack-operatingsystems-linux-nrpe4Error: Unable to find a match: centreon-pack-operatingsystems-linux-nrpe4 PS: I am trying to monitor Linux RHEL services launched with systemdThank you for your help.Regards.
Hello,anyone know how to exclude a system partition that does not have a letter? As a workaround a regex that exlude partition with less than 500mb could do the job too.thanks in advancebest regards,
Hello !We have upgraded our Rubrik clusters to version 9.4.However, in version 9.4, Rubrik no longer supports the use of service accounts on clusters, but only on the RSC console.The “Rubrik REST API” plugin is designed to connect only to clusters and not to the RSC console.Is it possible to have a plugin that is compatible with RSC ?Or has any user found a workaround?
Hello, just a realization, but maybe it’s mean to work like this, but i don’t believe there is a CLAPI configuration to set the macro description for a CMD command.I realized that when exporting some configuration i did on a centreon to reuse it later, only the argument decsription was exported and not the ones from the service and host macros.Is there an API that maybe is not referenced on the documentation ?Command Line API (v1) - CLAPI | Centreon Documentation
Bonjour, J’ai besoin de votre aide.Nous avons installé un serveur centreon en version 24.10.4 sur une base de debian 12 et avons configuré Nagvis en version 1.9.44De manière générale, l’ensemble est fonctionnel, seulement la connexion à l’un engendre la déconnexion de l’autre, peu importe le type de connexion configuré sur centreon (Single NagVis user auth or Centreon user auth ?)Nous rencontrons des déconnexion aléatoire sur l’un comme sur l’autre.Auriez vous des pistes SVP?Merci d’avance
Hi, after migration centreon 24.10.x to another Server .. Alma 9 to RedHat 9SELinux disabledsame IP this issue The HTTP status code "10" is not valid. ?
Bonjour,Est-ce que le support de RHEL 10 est prévue? Au moins pour la partie plugins? Pour le moment, il n’y a pas de repository disponible dans cette version.Merci,Yannaël G.
Hi all,I’ve built a new centreon server 25.10 on alma 9, its hasn’t got a license so I guess its the open source edition, will it be restricted to 100 hosts?cheerssteve.
on centreon 23.10.5, when i export configuration, i have no error but we need to reload/restart centengine service to apply it. this command worksssu - centreon-gorgone -s /bin/bash -c 'sudo systemctl restart centengine' here the permissions of :centreon [root@centreon ~]# ls -l /etc/centreontotal 36-rwxrwxr-x 1 centreon centreon 1276 Mar 26 11:42 centreon.conf.php-rwxrwxr-x 1 centreon centreon 390 Mar 26 16:18 centreontrapd.pm-rwxrwxr-x 1 centreon centreon 282 Mar 11 2024 centreon_vmware.pmdrwxrwxr-x 2 centreon centreon 4096 Mar 14 2024 config.d-rwxrwxr-x 1 centreon centreon 103 Mar 14 2024 config.yaml-rwxrwxr-x 1 centreon centreon 747 Mar 26 16:18 conf.pm-rwxrwxr-x 1 centreon centreon 612 Mar 14 2024 instCentPlugins.conf-rwxrwxr-x 1 centreon centreon 929 Mar 14 2024 instCentWeb.confdrwxrwxr-x 2 centreon centreon 4096 Mar 14 2024 license.d centreon-engine [root@centreon ~]# ls -l /etc/centreon-engine/total 408-rw-rw-r-- 1 apache centreon-engine 4508 Sep 16 18:37 cent
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.