Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,I am trying to add a check on a web page to ensure it is up and running. I tried with the HTTP plugin with the HTTP-Response-Time service template. By default it will fail only if the web server is not responding but it will be OK even with a 404 error for exemple. So I guess I have to use the option --critical-status to check that return code is 200. This gave me the following command/usr/lib/centreon/plugins//centreon_protocol_http.pl--plugin=apps::protocols::http::plugin--mode=response--hostname=myhostname--proto='https'--port='443'--urlpath=''--warning=''--critical=''--http-peer-addr='my_web_page_url'--critical-status='%{http_code} != 200'However when the web page URL returns a status different from 200 the test is still OK.I guess I should use a different syntax for the --critical-status parameter? But all the exemples I found refers to this syntax.I might have to use a different plugin or template to do what I seek? But I could not find which one then.Your help or comments are
Hello,I’m looking for someone to help me install remote connectors on a centreon centralI try to follow documentation but each time, unable to connect the remote to the central after the installation…Someone available to make it together on Discord or other please ? Very big thanks !
Hi everyone,I'm using the open source version of Centreon (no license, no commercial subscription) and I would like to monitor equipment like Cisco switches, HP servers, UPS, PDUs, etc. using SNMPv3.I know that with a commercial license, I could simply use the Monitoring Connector Manager to install packs like network-cisco-standard-snmpv3, but in the open source version, only basic modules are available and the rest require a license.That said, I was able to install centreon-pack-operatingsystems-linux-snmpv3 via APT, and it works perfectly for Linux hosts using SNMPv3. So I assume it's technically possible to use SNMPv3 monitoring for other devices as well, but manually, without licensed packs.I’ve already cloned the official centreon-plugins GitHub repo and I can run checks via CLI successfully. How should I configure them properly in the Centreon web interface (host templates, service templates)?This is part of a large-scale migration from SNMPv2 to SNMPv3 across many existing devi
Good Morning! I get many info messages in my centreon_vmware.log like this one: [info] vpshere 'default' handler asking: {"free":null,"sampling_period":null,"filter_os":null,"identity":"client-48cbb13ab1b245d8b5387abf783813dc","units":"%","unknown-status":"$values->{connection_state} !~ /^connected$/i or $values->{power_state} !~ /^poweredOn$/i","warning-overhead":"","critical-ballooning":"","filter_counters":null,"filter_counters_block":null,"critical-shared":"","connector_port":"5700","display_ok_counters":null,"display_description":null,"time_shift":0,"unknown-overhead":null,"warning-status":"","vsphere_username":null,"command":"memvm","list_counters":null,"filter":null,"connector_hostname":"localhost","warning-active":"","warning-shared":"","filter_description":null,"critical-overhead":"","vm_hostname":"_____HOSTNAME"______,"scope_datacenter":null,"unknown-consumed":null,"warning_connector_status":null,"scope_cluster":null,"unknown-ballooning":null,"scope_host":null,"critica
Hey everyone,I’m setting up Centreon and I’ve hit a point where I’m confused about how Monitoring Connectors, plugins, and the GitHub plugin repo all relate — especially when it comes to licensing and offline environments.Here’s my current situation and questions: After a fresh install of Centreon, I could install some Monitoring Connectors (I think these are the default/free ones). But I also see many others greyed out — I assume those require a license? I understand that Monitoring Connectors (or Plugin Packs?) are templates that help configure services, but I’m not sure how they relate to the actual plugin scripts (like those in /usr/lib/centreon/plugins/). I also don’t really get the relationship with the GitHub repo (https://github.com/centreon/centreon-plugins). Can I just clone that repo and use it without a license? if I clone it will i be able to use all plugins and won’t need to install connectors/packs etc? If I do clone the GitHub repo, should I clone it on the Centra
Bonjour, Nous avons fait un backup de notre serveur Centreon avec les paramètres suivant :Jusqu'à la, pas de souci. Cependant lors de la tentative de restauration sur une autre machine avec configuration identique (même debian / même version de centreon / même paquet d’installation), nous avons une impossibilité de se connecter, pas de message d’erreur.Le pas à pas suivi est présent sous ce lien : https://docs.centreon.com/fr/docs/administration/backup/Nous sollicitons votre aide!Anthony
Bonjour à TOUS.Nous avons besoin de votre aide et de votre expertise.Nous avons pour projet de rapprocher plusieurs serveurs centreon afin de regrouper les informations.Après plusieurs tentatives infructueuses, je n’arrive qu’a exporter les données de mon centreon A vers mon centreon B ou inversement mais les données qui sont exporter ne sont plus accessible sur le centreon initiale. (si A envois vers B, les données de A sont visible sur B mais les données de B ne sont plus accessibles et si B envois vers A, les données de B sont visible sur A mais les données de A ne sont plus accessible) Peut-on récupérer les informations de plusieurs centreon en 1 mais conserver leur indépendances? Merci d’avance Hello everyone.We need your help and expertise.We have a project to bring together several Centreon servers in order to consolidate the information.After several unsuccessful attempts, I can only export the data from my Centreon A to my Centreon B or vice versa, but the exported data is n
Hello,I'm running Centreon and trying to use the plugin hardware::hds::csu::rest::plugin (internally developed but issue is not related to the plugin) to monitor an HDS storage system via REST. However, I'm getting the following error when executing the plugin manually:UNKNOWN: Can't call method "add_options" on an undefined value at /usr/lib/centreon/plugins/centreon-plugins/src/centreon/plugins/http.pm line 32.Here's the command I'm running:perl /usr/lib/centreon/plugins/centreon-plugins/src/centreon_plugins.pl \ --plugin=hardware::hds::csu::rest::plugin \ --mode=alerts \ --custommode=api \ --hostname=xxxxxx \ --username='localhost\xxxxx' \ --password='xxxx' \ --csuid='4c4c4544-0046-4210-8033-b8c04f335732' \ --ssl-opt='SSL_verify_mode => SSL_VERIFY_NONE'Additional notes: All required Perl packages (e.g. perl-libwww-perl, perl-LWP-Protocol-https, etc.) are installed. Basic plugin tests like check_ping or check_memory work fine using the same Perl binary and environment.
Hi all,I'm trying to use the Centreon plugin for VMware (apps::vmware::connector::plugin) on a poller running RHEL 9 / AlmaLinux 9. The plugin fails with the following error: UNKNOWN: Cannot load module --custommode. Can't locate ZMQ/LibZMQ4.pm in @INC (you may need to install the ZMQ::LibZMQ4 module) (@INC contains: /usr/lib/centreon/plugins/centreon-plugins/src ...) I installed zeromq and zeromq-devel from the default system repo, which provides version 4.3.4. However, ZMQ::LibZMQ4 requires libzmq headers to compile, and Centreon’s own repo (centreon-24.10-stable) provides zeromq-devel-4.3.5, which conflicts with the system-installed version: Error: Problem: package zeromq-devel-4.3.5-1.el9.x86_64 from centreon-24.10-stable requires libzmq5 = 4.3.5-1.el9, but none of the providers can be installed - libzmq5-4.3.5 conflicts with zeromq 4.3.4 from @System Since Gorgoned is already running using the system version of zeromq, I don't want to risk breaking it by replacing it.I’m not sure
Hello,Is so possible to use Centreon MAP with IT100 ? or purchase business edition ?Thanks
Hello, Could you please recommend a plugin for Centreon that can monitor a mailbox and alert if emails do not come? Or is there a way for us to implement this? Thank you,Crisanto
Hi,I have recently installed Centreon 24.10.7 on premise on Alma linux 9.5A temporary 60 days license was provided and installed. On the page: Configuration > Connectors > Monitoring Connectors the message “No monitoring connectors found” appears. The online documentation says:install the Monitoring Connectors repository (go to the Centreon support portal for its address) Obviously, without the repository the installation isn’t possible:# dnf install centreon-pack-*Last metadata expiration check: 7:24:42 ago on Wed May 14 06:48:52 2025.No match for argument: centreon-pack-*Error: Unable to find a match: centreon-pack-* Could you provide me the repository details? Regards,PerBacco
Hello, I'm asking for your help because I recently installed a new Centreon server in version 24.10.7 on a Debian 12 and I'm constantly getting errors for various things that I encounter only in HTTP and never in SSH, in particular for creating a Host. When I want to create one via Web UI and I click on the “Save” button to register my new host, nothing happens and my centreon WEB interface crashes for a few dozen seconds.Another thing is that when I perform various other actions, I constantly get the following messages: “failed to fetch” “Oops, something went wrong” at the bottom of the page. Any idea where this might be coming from?I'm also attaching the source code inspection with Google CHROME to show you the type of error that keeps appearing.Thanks in advance.
Hello, I have an issue with Backbox Plugin and I don’t know if someone experienced the same.For “Backup” mode, all is ok, So API Token is validated :-)But for “Device-Backup” and “ConfigStatus” modes, I have a “404 not found” issue. In command Line, for “Device-Backup”, I thnik there is an issue related to urls in plugin.It does a GET on 2api/devices” and give a result:But just after, try to join “/rest/data/token/api/devices/dynamic”and this 2 times… I don’t think “Dynamic” exists.Maybe someone experienced this??? Regards, Laurent
Hello,I have around 1000 VMs which I added initially into host groups like prod, preprod, uat etc. The VMs are a mix of windows and linux. Now since I will be using snmp templates and some will use linux_snmp and some will use windows_snmp templates, I want to create 2 new host groups - windows and linux. Now I want to add my hosts into these host groups. What would be the easiest way to do it please? via csv import for example. How to add my already added hosts to these new groups without impacting the existing hosts or host groups. For example, I cannot delete and readd all hosts with updated host groups. I dont have autodiscovery license.
Hello;i just fresh install a server central with the automatic processus “Unattended installation of a central server” version 24.04once installed , i set the https access to the central GUI and i can connect on it with a self certificate. Now i would like to register a remote server with same process install “Unattended installation of a central server” version 24.04”.once installed, when i run /usr/share/centreon/bin/registerServerTopology.sh -u admin -t remote -h ipcentral -n remoteserver1 --insecurei have this issue: 2024-09-04 18:25:46+02:00 - ERROR - ip remoteserver: {"code":500,"message":"Request to the Central's API failed : Recv failure: Connection reset by peer for \"http:\/\/ipcentral\/centreon\/api\/v24.04\/login\"."} could you help me?thank
Hello everyone I had deployed a machine as a poller and connected it to centreon, then later i exported it to a different network and wanted to attach it to a different centreon server, however the command “/usr/share/centreon/bin/registerServerTopology.sh -u admin -t poller -h 192.168.0.1 -n poller-1’ was run succesfully and I could see the poller in the list when I went to add it, however when It came to the gorgoned file I click to copy the contents and I see the error above, I’m unsure what I’m supposed to do, I deleted the old gorgoned file and restarted the service on both the central and the poller, and redeployed the poller and added it again, still same issue, I’m unsure what I should do, I also deleted the log files and the key files: rm -rf /var/lib/centreon-gorgone/.keysrm -rf /var/log/centreon-gorgone/*
In the Monitoring > Map menu of the Centreon web interface, in 21.10 version, what are the prerequisites for displaying the different MAPs that we create with our heavy client? I can see them, but my colleagues can’t, and I don't know why, since we belong to the same groups so the same rules are applied to us. Do we need to change something at the ACL level ? Is there any parameters on their profile that I need to change ?
Hello,I install the last connector but on plugins folder there isn’t a pl file to excecute the plugin.Anyone have solved this problem?Thanks
Hi, I have a poller with many Oracle databases monitored by Centreon’s plugin centreon_oracle.pl.But I have a lot of trace files in directory “/var/tmp/oradiag_centreon-engine/diag/clients/user_centreon-engine/host_<123456789>_<123>/trace”.This leads my poller to ran out of inodes:Filesystem Inodes IUsed IFree IUse% Mounted on[...]/dev/mapper/vg0-racine 1237888 1237888 0 100% /[...] There is a way to avoid that?
I made a manual offline installation on a redhat 9 server of centreon 24.04. After correcting some things, I thnik my installation is not the cleanest but should be working. Instead, everytime I go to the centreon login page I have a big centreon logo, a You need to enable JavaScript to run this app message and if I check the inspect page and the access logs, I have a 404 error on /centreon/api/latest/platform/installation/status, and I cant find this file anywhere??
Hello,I have different resources named “Traffic” (from an interface) that i want to put on a view, on Centreon MAP 21.10. But when i select “Geometric style”, a green little triangle appears. I want to increase it size, so we can be able to see it when we’ll display the view on a screen, but increasing the size (by stretching the corners) just increase the size of the surface of the icon, and not the size of the triangle properly. Do you have any other solution so we can see it more easily ?
Hello,Im following the migration guide:https://docs.centreon.com/docs/migrate/migrate-from-el-to-debian/#prerequisites After done the steps 4 adn 5 from Step 2 : Synchronize the data, i cant log in the web interface, i got this error Before done this steps i was be able to login with local admin.How can i fix it? Thanks,
Hello guys,Everytime I try to update to a newer version of Centreon starting from Centreon 24.04.4 to a newer version, the update gets stuck on "Congratulations, you have successfully upgraded to Centreon version 24.04.11”. The page that it’s stuck onWhat I have tried so far:I try to update to version 24.10 after to see if it resolved the problem (which it didn’t )I checked the storage, there is still plenty.I checked that all the services required were at the right version and started. (but I could have missed one)In the installation process I get prompted those lines :chmod: cannot access '/var/cache/centreon/config/engine/*': No such file or directorychmod: cannot access '/var/cache/centreon/config/broker/*': No such file or directorySo i’m wondering if it could be a rights attribution problem.Also when I click the finish button I get prompted for a quarter of a second the following:The error that gets displayedBut it could be unrelated. Do you guys have any ideas about what could b
Hello , I am upgrading my platform from 23.10 to 24.10. But while upgrading centreon 24.10 need GLIBC_2.34 and upward. So how can we upgrade GLIBC? How can i Proceed further? Thank You
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.