Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Subject: Issue with Duplicate Alert Count on Centreon Dashboard Hello,I am experiencing an issue with one of my Centreon dashboard where it displays 4 services in a "Warning" state, although in reality, there are only 2 services in that state on this Host. It appears that the dashboard is doubling the number of alerts displayed.Do you have any solutions for this problem? I would like to understand why this discrepancy is occurring and how to resolve it.Thank you for your help.Best regards,
I am looking for interesting services to add for a Mikrotik router. Any ideas?
hello,i must create a new monitor with Pure Storage FlashArray Rest API v2 on the arraysi dont undestand the status of --critical-read or write on --plugin=storage::purestorage::flasharray::v2::restapi::plugin --mode=arraysi dont know what the value for a filterthanks
Hi,I'm new to Centreon (24.04), and I'm probably missing something.I want to add my host via the API (using Ansible). I managed to do it using this endpoint: /centreon/api/latest/configuration/hosts.The host creation is successful, and it's linked to the correct template, but no services are created.How can I achieve this, similar to the option in the host creation GUI that says "Create Services linked to the Template too"?I've looked everywhere in the API documentation but couldn't find any clues: https://docs-api.centreon.com/api/centreon-web/#tag/Host.Can someone please help?
Hello everyone, I have just installed centreon on a debian 12 vm based on proxmox. During my installation, I noticed at step 6 that I don't have access to my mariadb screen database. I looked for different errors in the mariadb, php or apache2 web server logs and I found this: [Thu Nov 07 16:31:35.823210 2024] [proxy_fcgi:error] [pid 31742:tid 31742] [client 10.16.6.232:59204] AH01071: Got error 'PHP message: [2024-11-07T16:31:35+0100] [CRITICAL] Environment variable not found: “hostCentreon”. {“context”:“[object] (Symfony\\\\Component\\\\DependencyInjection\\\\Exception\\\\EnvNotFoundException(code: 0): Environment variable not found: \\”hostCentreon\“. at /usr/share/centreon/vendor/symfony/dependency-injection/EnvVarProcessor.php:217)”}”,however, I did declare my centreon host in the various conf files in .env and conf.php. I'm using:mariadb version 10.11.10php version 8.2.25apache 2 version 2.4.62 I'm completely lost when it comes to this, and I really need it quickly, as this infra
Hi, We use Centreon 23.10.17 on redhat 8.10.While trying to simulate the update to Centreon 24.04.XX, I get this message in the dnf update output : replacing centreon-widget-engine-status.noarch 23.10.0-1.el8 replacing centreon-widget-global-health.noarch 23.10.0-1.el8 replacing centreon-widget-graph-monitoring.noarch 23.10.0-1.el8 replacing centreon-widget-grid-map.noarch 23.10.0-1.el8 replacing centreon-widget-host-monitoring.noarch 23.10.1-1.el8 replacing centreon-widget-hostgroup-monitoring.noarch 23.10.0-1.el8 replacing centreon-widget-httploader.noarch 23.10.0-1.el8 replacing centreon-widget-live-top10-cpu-usage.noarch 23.10.0-1.el8 replacing centreon-widget-live-top10-memory-usage.noarch 23.10.0-1.el8 replacing centreon-widget-service-monitoring.noarch 23.10.0-1.el8 replacing centreon-widget-servicegroup-monitoring.noarch 23.10.0-1.el8 replacing centreon-widget-single-metric.noarch 23.10.0-1.el8 replacing centreon
Bonjour,Je n’arrive pas a faire fonctionne le mode pull avec gorgoned. Sur le central, j’ai ce message la 2024-11-07 11:59:37 - INFO - [core] Connection from gorgone-412024-11-07 11:59:42 - DEBUG - [proxy] Send message: [channel = control] [action = PING] [token = ] [target = 35~~35] [data = {}]2024-11-07 11:59:42 - DEBUG - [proxy] skip node pull target '41' for node '41' - never connected2024-11-07 11:59:42 - DEBUG - [proxy] no pathway for target '41' La communication se fait car si je m’amuse a enlever authorized_clients:, j’ai bien dans le log que le poller n’est pas autorisé.J’ai un doute si ca ne serait pas le fait de passer par un haproxy.
I installed a distant poller for my Centreon Central on a different network, it worked fine for a time, but one day the export configuration stopped working, it stop on the Generating files step : I checked centreon-gorgone privileges and it has all permissions but in the gorgoned log file, i got this error when reloading :2024-11-08 09:55:17 - ERROR - [statistics] Error updating RRD file '/var/lib/centreon/nagios-perf//perfmon-2/nagios_hosts_states.rrd': opening '/var/lib/centreon/nagios-perf//perfmon-2/nagios_hosts_states.rrd': Permission deniedHow to fix ?
Hello All.My first question on this forum !I migrated our Centreon server to Debian 11 one year ago and sized all the volumes as per the recommandations. Lv_log is 10 GB. The version of Centreon is 24.04.7I recently remarked this volume was full because of the file /var/log/centreon-engine/centengine.log. There is enough free space on the volume group so I increased the size of the logical volume.But this file is increasing at a rate of about 6 MB per day, it’s size is now 7,6 GB. I don’t see any option to save an history of the file and start with a empty new one.Am I missing something ?Have a nice day.
Hello,Since upgrading to Centreon 23.10 (since 21.10), I've been experiencing frequent slowdowns in the Web UI.From time to time, I have to restart the Centreon server to restore service.Analysis has shown that a very specific request is the cause. This query crushes the performance of the MySQL server. It seems that the indexes are not being used (FULL SCAN).The query is attached.Can anyone help me identify the cause, usage or process that triggers this query?Here is the SQL request SELECT SQL_CALC_FOUND_ROWS DISTINCT 1 AS REALTIME, resources.resource_id, resources.name, resources.alias, resources.address, resources.id, resources.internal_id, resources.parent_id, resources.parent_name, parent_resource.status AS `parent_status`, parent_resource.alias AS `parent_alias`, parent_resource.status_ordered AS `parent_status_ordered`, parent_resource.ad
Hello,I wish to extract from Mariadb all hosts with their hostgroup.Is someone can help me ?
Hey !I'm coming to you today because I'm stuck with the centreon/postfix settings.I would like to change the sender email cent-engine@servercentreon to cent-engine@domain.frdespite the change of the main.cf filewith in particular the addition of $myorigin it still remains in @servercentreonHas anyone had the problem before?Thanks !
📢 End of Support for Debian 11 in Version 24.10 🚨We want to inform our user community that with the upcoming release of Centreon 24.10, support for Debian 11 will officially come to an end.Debian 11 is already in Long Term Support, and Centreon has been supporting Debian 12 since 24.04.We will support in-place OS upgrades from Debian 11 to Debian 12 which you can perform with 24.04 before upgrading to Centreon 24.10.We appreciate your understanding as we continue to focus on providing the best possible monitoring solutions.For any questions or support, please don’t hesitate to reach out via our community forums or customer support. We’re here to help! Don't forget to subscribe to the Latest News, Product Updates and Security Bulletins sections to stay informed in real-time about the latest information, latest security bulletins, minor and major updates, and monthly releases of monitoring connectors. Stay in the loop!
Hello,I would like to know if anyone has managed to supervise backup jobs with Veeam for AHV.I supervise my veeam backup jobs through the NRPE plugin but only the hyper-v and vmware jobs appear.Thank you in advance for your knowledge
Hello,I have a problem with centreon_storage.logs table and partitioning.I’ve drop table, remove /var/lib/mysql/logs*.frm and .idb I recreated the table with contents of file :/usr/share/centreon/config/partition.d/partitioning-logs.xmlCREATE TABLE `logs` ( `log_id` bigint(20) NOT NULL AUTO_INCREMENT, `ctime` int(11) DEFAULT NULL, `host_id` int(11) DEFAULT NULL, `host_name` varchar(255) DEFAULT NULL, `instance_name` varchar(255) NOT NULL, `issue_id` int(11) DEFAULT NULL, `msg_type` tinyint(4) DEFAULT NULL, `notification_cmd` varchar(255) DEFAULT NULL, `notification_contact` varchar(255) DEFAULT NULL, `output` text, `retry` int(11) DEFAULT NULL, `service_description` varchar(255) DEFAULT NULL, `service_id` int(11) DEFAULT NULL, `status` tinyint(4) DEFAULT NULL, `type` smallint(6) DEFAULT NULL, KEY `log_id` (`log_id`), KEY `host_name` (`host_name`(64)), KEY `service_description` (`service_description`(64)), KEY `status` (`status`), KEY `instance_name` (`instance_name`
Bonjour, All is in the title: Is it possible to change service inherit_contacts_from_host value with an api ? Thanks,Mathias
Bonjour,Comment interroger une API avec une clé API svp , et récupérer une valeur svp.en CLI pas de soucis :Mais impossible dans le plugin http-jason-content : j’ai une erreur 401,ou mettre le clé aPI svp ?Merci d’avancecordialement
Hello, We are using a Android TV to display the Centreon Monitor view. In Centreon version 24.04, the url parameter `min=1` is not available to display Centreon in full screen without header. But on the AndroidTV we haven’t keyboard connected on it. And the monitor restart all sunday.Is it possible to put again the query parameter `min=1` in the Autologin URL ? Thx
Hello,I recently updated my centreon to 21.10, I have a problem with the time and date format, it remains in 12H format and the date MM/DD/YYYY Thank you in advance for your helpKélian
Hello,Yesterday we tried to migrate our Centreon infrastructure from 24.04 to 24.10.Following this, we are encountering two main errors: The first, errors in the sudoers.d/centreon fileThe second, a problem with a .DEBUG file where the values are err instead of error, and this is causing errors on the machines when the configuration is exported.To resolve this, we modified the sudoers.d/centreon file by hand to apply the full executable pathsAs well as modifying the engine configuration so that the log level is not ‘Error’ but something else such as warning or critical.Can you see how to resolve this please? Because if we have to go to each machine to make these changes by hand, which are more workarounds than anything else...Thank you
Hello, I have set up a remote poller that I am trying to connect to my central server. Both servers are running Alma OS 8.1, with Centreon version 24.04.5 for the central server and version 24.04.6 for the poller. I followed the documentation to do this, and when I run the command:/usr/share/centreon/bin/registerServerTopology.sh -u <API_ACCOUNT> -t remote -h <IP_TARGET_NODE> -n <REMOTE_SERVER_NAME> --insecurea connection is established. However, after adding it in the Centreon GUI, the poller remains in a "not running" state, and I have no errors during the exports. file:I noticed the following error in the Gorgone log :2024-10-01 05:28:36 - ERROR - [proxy] Send message problem for '21': 2024-10-01 05:29:26 - ERROR - curl perform error: SSL peer certificate or SSH remote key was not OK2024-10-01 05:29:26 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - http request error2024-10-01 05:29:36 - ERROR - [proxy] Send message problem for '2
Hello everyone and thank you for your attention,there is a few issues that i encounter since some time with my dashboard experience in Centreon.For context, the service i’m having the most problem with is a custom service that returns the 10 users that use the most cpu on one server.the service uses a script and returns each time 10 metrics with this format *user1*_cpu = 6% ; *user2* … The problem happens when i want to display this in a graph or any other display tool, because my metrics are dynamic, each time it runs the metrics names change as well (if there is a change in which user uses more cpu).For some time now my solution was to manually add all the new metrics in the graph until all of the users were covered but a graph with 90 metrics or so is very unstable even if there is only 10 active at a time.All that i want is to display the 10 users that are returned by my service and the value associated with it but i can’t find a good solution.I’ve had a few idea on how to solve th
I am currently working on a project which consists of retrieving data from the MySQL database already installed on the Centreon poller and displaying it on Grafana.I am looking for plugins or solutions to facilitate this integration. Could you advise me on the steps needed to configure Grafana so that it can access the MySQL database and display the data?If anyone has done this before or knows the necessary commands, your advice would be greatly appreciated!Thank you in advance for your help!
HelloNeed a Help How to interprate this comman /usr/lib/centreon/plugins//centreon_protocol_http.pl --plugin=apps::protocols::http::plugin --mode=expected-content --hostname='******************l' --proto='http' --port='80' --urlpath='/app/*****************/' --critical-content='%{content} !~ /<title>**********<\/title>/mi' --http-backend='curl' --curl-opt='CURLOPT_ACCEPT_ENCODING => gzip'OK: HTTP test(s) | 'size'=1183B;;;0; 'time'=0.042s;;;0;
I need always show the severity column for my users. its a important information for the service desk team.Now, after each login I need click in 'Add column' and select 'severity'.It's possible set to show the 'Severity column' by default for all users?Thanks
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.