Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello I am looking to integrate a theme in centreon MBI to customize the color of my reports. I added the.css file in /usr/share/centreon-bi/Resources/CSS but I can't find it on the Centreon web interface. Has anyone ever tried to customize the colors of the report templates?Maybe I didn't put my CSS file in the right folder?Thank you in advance
Hello everyone,I've set up a 4-node HA architecture (currently in version 23.04.19) under debian.I've noticed that the backups don't work at all. Looking at the https://docs.centreon.com/docs/23.04/administration/backup/ doc and the /etc/cron.d/centreon file, nothing is specified. I also looked at the /etc/centreon-gorgone/config.d/cron.d/10-centreon-ha.yaml file and found nothing about this.Am I the only one with this problem?Bonjour à tous,J'ai mis en place une architecture HA 4 nœuds (actuellement en version 23.04.19) sous debian.j'ai remarqué que les backups ne font pas du tout. En regardant la doc https://docs.centreon.com/docs/23.04/administration/backup/ et le fichier /etc/cron.d/centreon rien n'est renseigné. J'ai regardé aussi du côté du fichier /etc/centreon-gorgone/config.d/cron.d/10-centreon-ha.yaml rien à ce sujet.Suis-je le seul à avoir ce problème ?
Hello,The broker statistics display of a poller is empty on the interface.I'm on version 22.10.How can I solve the problemThankPhilippe
Hello,I added the HP Proliant plugin, the snmp is configured correctly on the server.The feedback from the plugin is the same regardless of the service: OK: All 0 components are ok [].When I run it from the terminal, I get this feedback:OK: All 0 components are ok [].Product Name: unknown, Serial: unknown, Rom Version: unknownChecking cpuChecking ide controllersChecking ide logical drivesChecking ide physical drivesChecking power convertersChecking power suppliesChecking sas controllersChecking sas logical drivesChecking sas physical drivesChecking scsi controllersChecking scsi logical drivesChecking scsi physical drivesChecking fca host controllerChecking fca external controllerChecking fca external accelerator boardsChecking fca logical drivesChecking fca physical drivesChecking da controllerChecking da accelerator boardsChecking da logical drivesChecking da physical drivesChecking fansChecking physical nicsChecking logical nicsChecking temperaturesChecking iloChecking memorySometime
Hi,I have to migrate an old Centreon 22.10.9 installation on Centos 7 to a new one on Alma Linux 8.The following licenses are installed:[root@cntcentral license.d]# ls -l /etc/centreon/license.dtotal 16K-rw-r----- 1 apache apache 1.1K Jul 20 2022 bam.license-rw-r----- 1 apache apache 1.1K Jul 20 2022 epp.license-rw-r----- 1 apache apache 1.1K Jul 20 2022 map.license-rw-r----- 1 apache apache 1.1K Jul 20 2022 mbi.license The new installation was created to substitute the old one, but it has not licenses yet;is it possible to transfer the old licenses to the new installation?Regards,Egidio
Problem:Every morning at 7am Centreon sends a notification (including to our ticketing system) that certain hosts are down. However, the hosts are not actually down at that time, and there is absolutely no “down” entry under “timeline” for the affected hosts at 7am, but there is one at 4:33am with 3 tries.Question:Could it be that the notification is delayed? If so, where can I check that? Related problem:No host UP notification is sent out, so the ticket does not get automatically closed either. What could be the reason?
Hello,when I'm in http, it works normally locally and on the network.When I switch to https, it works locally but not on the network.If I leave the possibility of connecting via http, I can therefore connect everywhere via http and only locally via https.I can't find the solution anywhere.Does anyone have an idea?THANKS.
Hi,I’ve updated my Centreon HA servers from 23.04 to 24.04, but since then I have 2 problems :- I can't reload the configuration from the Pollers > Export configuration menu.With the help of this topic: upgrade 22.04 to 22.10 : many php mwarning with php-pecl-gnupgI get this error:I found this message in the log file /var/log/centreon/centreon-web.log[2024-07-09T12:11:31+0200] [ERROR] [Centreon\Application\Controller\Configuration\MonitoringServerController:229]: Generation error on monitoring server #6: Authentication token expiredI haven't found anyone with the same problem and don't know where to look to fix this token problem. - cron jobs managed with gorgone no longer run since the updateI received alerts for partition tables that were out of date and checked the logs. > I've had errors with the autodiscovery module, which we don't use, so I've disabled it by renaming the yaml configuration files to .disabled.2024-07-09 17:31:55 - ERROR - [autodiscovery] -class- host discove
Hello,I tried SNclient+ and I will share what I found with this short review.My thirst thought is that SNClient+ is mainly for Windows host.s Why ? Because I failed to installed it from Debian 5 to Debian 11 included. The Debian packages are broken on all theses releases, you can’t install it, it will throw an error.The answer from the team was if it’s not working you can try to recompile it from sources.It more sunny on the RedHat side because the RPM is valid (and tested) on RedHat 7 and 9 (I didn't test it on RH8).Also, only a unit for Systemd is included, no Init script.On the Windows side, it’s unclear on which version we could run it.I successfully run it on Windows 2019 but the SNClient+ team don’t give a list of supported OS :https://github.com/ConSol-Monitoring/snclient/issues/48 I tried some check with «check_nrpe» as I’m used to with NSClient++.Some are identical, like theses :$ /usr/lib64/nagios/plugins/check_nrpe -H 10.128.10.7 -c check_drivesize -a Drive=C: ShowAll MinWar
I am getting an execution error when scanning linux hosts with NRPE. No issues on the Windows hosts. Using 23.10
Hello,I am trying to create a MetaService with a SQL Matching selection, but I can not find in the documentation nether on the internet, an example of it. Moreover, I can not find the SQL structure definition to try with it. Can anyone give some guidelines for this? Thanks in advance.Regards, Lluís Clavaguera
Hello everybody,I have installed a Centreon 24.04.2 Central server with several pollers.I use the ZMQ revese flow from the pollers to the Central.I have enabled TLS encryption (forced to “Yes”) with self made certificates on the Broker configuration for the communications between pollers and the Central (Input on the Central and Output on the poller).Everything is Green on the Poller in the GUI. I can Reload/restart/DoCheck on the poller, All work well.However, I have noticed High CPU (99%) usage for the gorgone-proxy process on the Central.We have and old Centreon 21.04 also with several pollers and have no problem of CPU.Do I have missed something ? Or Did I make something wrong ?Thank you for your answer.Best RegardsPierre
Hello,I have migrated from Centos 7 22.10.23 to Alma linux9 running Centreon 24.04.5.I have only one Centron server doing everything.I’m able to mofiy host/service confguration and then export then (with Move Export Files + Restart Monitoring Engine) without error.But I’m unable to create a downtime maintenance… neither from a host/service, neither directly from the menu Ressources -> Downtimes -> Downtimes. Nothing happend, nothing is created…Any Idea ?Thanks a lot Just notice this but I don’t know how to fix it :central-broker-master.log[2024-08-16T10:16:47.317+02:00] [config] [error] endpoint applier: The configured write filters for the endpoint 'centreon-broker-master-rrd' contain forbidden filters. These ones are removed[2024-08-16T10:16:47.317+02:00] [config] [error] endpoint applier: The configured read filters for the endpoint 'centreon-broker-master-rrd' contain forbidden filters. These ones are removedtail -f /var/log/centreon-broker/central-broker-master.log[2024-08-1
Hello,Does Centreon have to use Postfix to send email notifications? If I don't use Postfix, is there another way to send email?
Hi Legends, I did migrate centreon from 2.8.32 to 21.10 and I am not able login to centreon web. I am getting error “Your credentials are incorrect.”. I have tried both localhost and ldap credentials, both are not working./var/log/centreon/login.log -- is empty /var/log/centreon/ldapsearch.log -- result is below[02/03/2022 11:14] LDAP Error : Invalid credentials[02/03/2022 11:14] LDAP Connect : Bind : Invalid credentials[02/03/2022 11:14] LDAP Connect : connection error /var/log/centreon/ldap.log - is not available.I followed these steps and the upgrade was successful and I am still able to access CLI. Please help me.
we want to monitor wazhu agetent and manager using Wazuh Rest API host template:App-Wazuh-Restapi-custom we used and getting error UNKNOWN: 401 Unauthorized/usr/lib/centreon/plugins/centreon_wazuh_restapi.pl --plugin=apps::wazuh::restapi::plugin --mode=manager --hostname='****' --username='****' --password='***' --port='55000' --proto='https' --insecure --filter-process='' --filter-log='' --warning-processes-stopped='' --critical-processes-stopped='' --warning-processes-running='' --critical-processes-running='' --warning-log-error='' --critical-log-error='' --warning-log-critical='' --critical-log-critical='' --warning-log-warning='' --critical-log-warning='' --warning-process-status='' --critical-process-status='' --verboseThanks YouBest Regard
Hello everyone,Some of you have already seen the information and have already passed it on to us (thanks again for your vigilance and your feedback). Microsoft made this announcement at the beginning of July:Starting August 15th, 2024 we will be removing the Office 365 connectors feature from Microsoft Teams. We recommend Power Automate workflows as the solution to relay information into and out of Teams in a scalable, flexible, and secure way.We will gradually roll out this change in waves:Wave 1 – effective August 15th, 2024: All new Connector creation will be blocked within all clouds Wave 2 – effective October 1st, 2024: All connectors within all clouds will stop working How will it work on the Centreon side?We have started to address this change and hope to quickly have an updated notification script in beta for users who would be interested in helping us validate it. The Centreon release of the Teams connector update is currently scheduled for the August 2024 release which will t
🇬🇧Hello, Would it be possible to filter the curves used on the "Datastore-Usage-Global" probe? I have 7 LUNs from a storage array to monitor and some local datastores. However, with the information in bytes (B) free/used and in percentages (%) free/used, it gives me 4 times too much content when I want to use the graph. I just want to have the percentage used curves. And if possible, have everything in the same table; otherwise, I can always generate a graph per metric.Thanks 🇫🇷Bonjour, Est-ce qu’il serait possible de filtrer les courbes utilisés sur la sonde “Datastore-Usage-Global” ? J’ai 7 LUN d’une baie à monitorer et quelques datastores locaux. Sauf qu’avec les informations en octets (B) libre/utilisé et en pourcentages (%) libre/utilisé, ça me fait 4 fois trop de contenu quand je veux me servir du graph. Je veux juste avoir les courbes pourcentage utilisé. Et puis dans la mesure du possible tout avoir dans le même tableau, sinon je peux toujours généré un graph’ par métrique.
Hi,On a new installation with a central server and a remote poller, the poller does not run.I followed the guide https://www.centreon.com/centreon-troubleshoot-series-episode-1-help-my-poller-is-down/ Netstat for poller seems ok :sudo netstat -plant | egrep '5669|5556'[sudo] Mot de passe de admcent :tcp 0 0 0.0.0.0:5556 0.0.0.0:* LISTEN 917/perltcp 0 0 192.168.109.212:5556 192.168.109.211:59262 ESTABLISHED 917/perltcp 0 0 192.168.109.212:58450 192.168.109.211:5669 ESTABLISHED 1720/centengineNetstat for central seems ok : sudo netstat -plant | egrep '5669|5556'[sudo] Mot de passe de admcent :tcp 0 0 0.0.0.0:5669 0.0.0.0:* LISTEN 1198/cbdtcp 0 0 127.0.0.1:54920 127.0.0.1:5669 ESTABLISHED 1193/centenginetcp 0 0 127.0.0.1:5669 127.0.0.1:54920 ESTABLISHED 1198/cbdtcp 0 0 192.168.109.211:5669 192.168.109
Hi everyone,I’m runing Centreon 22.10.23 on Centos 7, and migrating to Debian 12 following this doc (https://eu-central-1.protection.sophos.com?d=centreon.com&u=aHR0cHM6Ly9kb2NzLmNlbnRyZW9uLmNvbS9kb2NzL21pZ3JhdGUvbWlncmF0ZS1mcm9tLWVsLXRvLWRlYmlhbi8=&p=m&i=NjUxYjE0ZGYxYzYxZDgxNTllOTFmOGEz&t=RnNobXpOMERrRlhWcmc5MTJiR1Zjcmh4c2tmdVFicFA2c3dRL202RkpJRT0=&h=88fcea6c9b85405b8eb764d52b9d3a03&s=AVNPUEhUT0NFTkNSWVBUSVYWn6ZWBeZKPjNzkzQdWhFdbGNZl4fRoI54YpLY0mFdhQ).The new server work fine until the Maria DB import steps… after that, I get auhtentication error "Error while searching authentication tokens" + "Error while searching for the widgets version of the Centreon platform"). Did you get also this errors ? any idea ??? :-S Thank you in advance,Best regardsSee below my log file. : /var/log/centreon/login.log:2024-08-06 11:33:35|38|0|0|[local] [127.0.0.1] Authentication succeeded for 'centreon-gorgone'2024-08-06 11:33:43|21|0|0|[local] [172.23.7.38] Authentication succeed
Hi,I am going to migration all poller to 24.x, and I can not see Jmeter plugin in list of plugin.I use --plugin=apps::jmeter::plugin with version of github todayis it possible to make this plugin officialThanks, https://github.com/centreon/centreon-plugins/issues/5137
Hi,We use Centreon 23.10.11.We have e Timeperiod linked to 400 services. This timeperiod is set to run the services everyday 08H-10H.The problem is that the Poller tries to run all of them at 08H00 … which leads to cpu load (on the poller) and also timeouts for some services ….The services are ran locally on the Poller (Not on remote hosts).The services are configured with a ‘Retry Check Interval = 8 minutes and a ‘Max Check Attempts=8”I juste need that these services to be run once a day but not necessary at 08H exact time.I just want to find a way to get these services execution dispatched (spreaded) in the Timeperiod (From 08H to 10H) …Example:service 1 : run at 08H00service 2 and service 3 : run at 08H01service 4: …. run at 08H04 … etc Any idea ? Thanks ?
Hello all,I desesperately try to migrate an old Centreon to the present version 24.04.4-1, I used the way described in the help pages, but that didn’t work, I now try to use clapi and export part of the centreon config, because the full one is so enormous that it cannot be exported as one only file…But when I try to import on the new Centreon 24.04.4-1, I always get this message…PHP Warning: Undefined array key 475 in /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php on line 981PHP Warning: Trying to access array offset on value of type null in /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php on line 981PHP Fatal error: Uncaught Error: Class "\CentreonClapi\centreon" not found in /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php:983Stack trace:#0 /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php(848): CentreonClapi\CentreonAPI->iniObject()#1 /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php(819)
Anyone know how to monitor VXRAIL in centreon?i read about api rest but did not make it, any good advice or website will be appreciate?Best regards
Hello,I was trying to import check commands using clapi. Failed with output:PHP Warning: Undefined array key 91 in /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php on line 981PHP Warning: Trying to access array offset on value of type null in /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php on line 981PHP Fatal error: Uncaught Error: Class "\CentreonClapi\centreon" not found in /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php:983Stack trace:#0 /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php(848): CentreonClapi\CentreonAPI->iniObject()#1 /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php(819): CentreonClapi\CentreonAPI->launchActionForImport()#2 /usr/share/centreon/bin/centreon(196): CentreonClapi\CentreonAPI->import()#3 {main} thrown in /usr/share/centreon/www/class/centreon-clapi/centreonAPI.class.php on line 983Did you have any expirience with this?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.