Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi everyone,I have this weird problem since my last upgrade, when I’m on Services page, graph icon don’t show up and have html code besides the service name : When I click on a host and go to his page, I get the icon displayed properly.Any idea on how to resolve this ?Thanks.
I would like to display multi líne status. I have tried \n at the end of each líne but it doesnt work, thanks for your time and answer
Hello, Has anyone found a solution to manage Unifi switches from Ubiquity? On my side I get the error:UNKNOWN: SNMP Table Request: Cant get a single value. I only have Ping and Uptime working.Oddly, my USG-Pro4 and my Wifi hotspot work fine. For the USG, you just have to remove the Access-point and SWAP control.CPU, Memory and Load are ok.
Hello , is there any syntax plugin with 2 package in repo 21.04?when i enter yum install centreon-plugin* i get :Transaction check error: le fichier /usr/lib/centreon/plugins/centreon_ibm_imm.pl entre en conflit avec les tentatives d'installation de centreon-plugin-Hardware-servers-ibm-imm-snmp-20220217-094259.el7.centos.noarch et centreon-plugin-Hardware-Servers-Ibm-Imm-Snmp-20220518-070245.el7.centos.noarch le fichier /usr/lib/centreon/plugins/centreon_masterclock_ntpserver_snmp.pl entre en conflit avec les tentatives d'installation de centreon-plugin-Hardware-Devices-Masterclock-Ntpserver-Snmp-20220217-094259.el7.centos.noarch et centreon-plugin-Hardware-Devices-Masterclock-Ntp100gps-Snmp-20220518-070245.el7.centos.noarch
hello everyone!When I add live-top10-memory-usage in the custom view. View shows 0 B remaining。like this, So what is the reason and how to analyze and solve it? thank you!by the way,There is no problem adding live-top10-cpu-usage in the same way.
Hello Community,I use the pass-manager Hashicorp Vault, and i have an issue about the help of this options. (I have a workaround, but i want to know if it’s a bug or a bad usage of the command.)I use centreon-plugins from Git Hub (Downloaded yesterday)Specially about this parameters :=item B<--secret-path>Location of the secret in the Vault K/V engine (Mandatory - Can be multiple).Examples:for v1 engine: --secret-path='mysecrets/servicecredentials'for v2 engine: --secret-path='mysecrets/data/servicecredentials?version=12'More information here: https://www.vaultproject.io/api-docs/secret/kv=item B<--map-option>Overload Plugin option with K/V values.Use the following syntax:the_option_to_overload='%{key_$secret_path$}' orthe_option_to_overload='%{value_$secret_path$}'Example:--map-option='username=%{key_mysecrets/servicecredentials}'--map-option='password=%{value_mysecrets/servicecredentials}'We have a Vault 1.6.3, use v2 Engine and if i follow the instruction on the help, my
HelloI’m trying to connect centreon to Azure do begin monitoring various elements, but I’m starting with Azure recoveryI tried to follow Superviser Microsoft Azure avec Centreon but whatever I do, I get an error whatever Azure plugin I try (I only tried cloud::azure::management::recovery::plugin and .cloud::azure::compute::virtualmachine::plugin)I’ll focus on cloud::azure::management::recovery::plugin, this uses the Azure Service Management API, I created the Active directory APP, created a secret like the article was saying but nowhere in the article or the doc could I find the “API Rights” to grant to App. I of course tried to add the corresponding api right to the App, and granted the admin consent, also added a few other rights as I’ll use this to also monitor some o365 service and that part was documented somewhere I’ve tried other right also, nothing worked whatever I do I get the same error I tried with the plugin pack or with the latest git pull from the repo:./centreon_plugins
Hi,I have noticed there are a lot of commnets in Monitoring>Downtimes>Comments section Can I or should I delete them? Thanks,Best regards
Bonjour à tous, J’aimerai savoir si il existe, une procédure, une manière de faire, pour convertir un remote server en centrale ? Un petit peu à la manière de la conversion d’un centrale en remote.Merci d’avance ! 😀 Hi there,I would like to know if there is a procedure, a way to convert a remote server into a central? A bit like converting a central to a remote.Thanks in advance ! 😀
Hello,I was thinking of migrating my Centreon Central Server currently running on a Centos7 to an AlmaLinux8 installation.How can I easily migrate my database between the two systems without loosing any data.And if you have other tips for me for this migration, I would be very thankful for that aswell!
Hello,since the latest version of centreon 22.04 a grafana plugin has been released, with you a procedure to install and configure it?Thanks
Hello,After installing the mssql package and updating my entire centreon 10 hours later I realize that I no longer have access to the interface which displays this message "Service Unavailable :The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later."I tried everything in vain, going back was useless, I am lostThanks for your help
Hello everyone,I am trying to get metric results using rest api request.I have enabled the rights to reach api configuration for the user.I get the api token by giving credentials via action authenticateBut when i use the token i get unauthorized access.Here are the commands used : curl -v -d "username=admin&password=centreon" -H "Content-Type: application/x-www-form-urlencoded" -X POST http://172.20.10.2/centreon/api/index.php?action=authenticate curl -v http://172.20.10.2/centreon/api/index.php?object=centreon_realtime_services^&action=list -H 'Content-Type:application/json' -H 'X-AUTH-TOKEN:6hwVYFtJerPts6JHopkN1qlZQ0xPo32DIUg2hOyyy220PPvQ3ANBWqiyEl11pxpv' And some screens for the result :
Hello , i’m trying to change the use of service template with apiv1I receive ‘missing parameters’ {'action': 'setparam','object':'service','values': “hostsrv;svc;template;template_name_to_use”} Is this correct ? or possible ? Any idea ?
Hello Community,I use Event Handler to realize remediation actions with others tools like Ansible, AWX or Ansible Tower.I’ve seen on a customer platform a 20.10, that the downtime is not a state who blocked an event handler to run.According to the documentation the downtime just skip the notification process.Anyone can confirm me is normal or it’s a bug ?What workaround could be put in place about that ?Regards,Greg
Hello everyone, I have a problem with my update, I have an error see below : log of upgrade.log :2022-06-01 12:49|0|0|UPGRADE - 22.04.0-beta.1: Unable to alter table security_token - Code : 42000 - Error : SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 3072 bytes - Trace : #0 /usr/share/centreon/www/class/centreonDB.class.php(309): PDO->query()#1 /usr/share/centreon/www/install/php/Update-22.04.0-beta.1.php(94): CentreonDB->query()#2 /usr/share/centreon/www/install/step_upgrade/process/process_step4.php(72): include_once('...')#3 {main}logs of sql-error.log :2022-06-01 12:49|0|0|SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 3072 bytes QUERY : ALTER TABLE security_token MODIFY token varchar(4096)i have check and test the solution of this issue of art3mis :Upgrade problem 21.10.6 to 22.04 but the problem still herecan you help me ? Regards
I upgraded my 21.10 platform to the 22.04 the May 23th at 21:40.The last logs available in the table centreon_storage.logs dates from the May 25th at 01:42.No more entry is available since this date.Monitoring and notification still works.No error seems present in the php and centreon broker logs. The partitioning seems to be done without problems.
Hello I just recently installed Centreon, so I added some hosts and added a custom snmp template to them.In Report>Dashboard on one of my hosts I have the following information: host status available, CPU service, RAM, Ping undetermined.In the status of resources I find the graphics of this host which are well fed.I therefore do not understand why it marks me that these services are indeterminate when they nevertheless work well.I don't know if there are a few more things to configure.Thank you for your answers,
JSON files not found: module-stats.json No such file or directoryIn the centcore.log file a lot af lines with this messages:cat: /centreon/appli/engine/lib/centreon-engine/prod-module-stats.json: No such file or directorycat: /centreon/appli/engine/lib/centreon-engine/prod-module-stats.json: No such file or directorycat: /centreon/appli/engine/lib/centreon-engine/prod-module-stats.json: No such file or directorycat: /centreon/appli/engine/lib/centreon-engine/prod-module-stats.json: No such file or directorycat: /centreon/appli/engine/lib/centreon-engine/prod-module-stats.json: No such file or directorycat: /centreon/appli/engine/lib/centreon-engine/prod-module-stats.json: No such file or directorycat: /centreon/appli/engine/lib/centreon-engine/prod-module-stats.json: No such file or directoryAnd by checking on the poller the json file is really missingll /centreon/appli/engine/lib/centreon-engine/prod-module-stats.jsonls: cannot access /centreon/appli/engine/lib/centreon-engine/prod-mo
Hello, I would like to know if it is possible to add notes at the resource level (red part that I have circled). Example for add comments, or tickets numbers, …Thanks !
How do I download the open source version?And how to confirm what version I am using?
Hi,I am trying to configure https following the centreon guide (Secure your platform | Centreon Documentation), so far everything seems to work fine in the console at least. No error on httpd.The problem is that i can’t access the website via my navigator, i get the error “xx.xx.xx.xx was too long to answer”. If i put back the old 10-centreon.conf everything works fine (but http only).Here a both version of the config file (it might be a stupid mistake but i can’t find it) :Header set X-Frame-Options: "sameorigin"Header always edit Set-Cookie ^(.*)$ $1;HttpOnly;Secure;SameSite=StrictHeader always set Strict-Transport-Security "max-age=31536000; includeSubDomains"ServerSignature OffServerTokens ProdTraceEnable OffDefine base_uri "/centreon"Define install_dir "/usr/share/centreon"ServerTokens Prod<VirtualHost *:80> RewriteEngine On RewriteCond %{HTTPS} off RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}</VirtualHost><VirtualHost *:443> ################
Hello, Since I Updated my Centreon platform in 22.04, when I try to install a new plugin pack (for example the new Protocol SFTP plugin) I receive the following error message : And if I check in /var/log/centreon/sql-error.log I can see this error : 2022-05-27 16:44|0|0|SQLSTATE[42S02]: Base table or view not found: 1146 Table 'centreon.mod_ppm_plugins_installation' doesn't exist QUERY : INSERT INTO mod_ppm_plugins_installation (pluginpack_id, package_name, command, version) VALUES (:plugin_pack_id, :package_name, :command, :version), null2022-05-27 16:44|centreon-pp-manager|0|Cannot save plugins requirements of Plugin Pack centreon-plugin-Applications-Protocol-Sftp It seems the table centreon.mod_ppm_plugins_installation is missing. Any ideas why the table is missing ?Should I create ite myself ? Thanks in advance
Hello to all,My company is currently migrating the monitoring of our infrastructure from Nagios to Centreon. We have already migrated a lot of Windows and we are still continuing. We will soon start the Linux. All our Linux servers are in Debian 10/11. For the moment, we have not yet found a Centreon-NRPE agent for Debian machines. I have the impression that the agent has been developed for CentOS or RedHat. Have you ever done monitoring via NRPE on Debian or Ubuntu systems?Thanks in advance for your answers which would be a great help!
Hello guys we are using centreon to monitor Linux and AIX servers using SNMP but there are snmp limitations for AIX servers we cannot monitor gpfs filesystems, memory, load which are required to be monitored. can we monitor these using agent? please note we are monitoring AIX version 7.2.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.