Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello ,after many year Centreon v. 21.10.15 don’t running anymore… I have look the log file here: /var/log/centreon-broker And i have found this: [2024-03-19T11:37:06.939+01:00] [core] [info] /var/log/centreon-broker//central-broker-master.log : log started[2024-03-19T11:37:06.939+01:00] [core] [info] modules: attempt to load '/usr/share/centreon/lib/centreon-broker/50-tcp.so' which is already loaded[2024-03-19T11:37:06.939+01:00] [core] [info] modules: attempt to load '/usr/share/centreon/lib/centreon-broker/80-sql.so' which is already loaded[2024-03-19T11:37:06.939+01:00] [core] [info] modules: attempt to load '/usr/share/centreon/lib/centreon-broker/20-storage.so' which is already loaded[2024-03-19T11:37:06.939+01:00] [core] [info] modules: attempt to load '/usr/share/centreon/lib/centreon-broker/15-stats.so' which is already loaded[2024-03-19T11:37:06.939+01:00] [core] [info] multiplexing: engine started[2024-03-19T11:47:21.008+01:00] [tcp] [error] Error while reading on socket: E
Hi, standard installation ok i installed the repodnf config-manager --add-repo https://packages.centreon.com/rpm-business/1a97ff9985262bf3daf7a0919f9c59a6/22.10/el8/centreon-business-22.10.repo all fine when i install dnf install centreon-bi-reporting-server error: dnf install centreon-bi-reporting-serverLast metadata expiration check: 0:08:22 ago on Mon 25 Mar 2024 11:10:03 AM CET.Error: Problem: package centreon-bi-reporting-server-22.10.8-1.el8.noarch from centreon-business-22.10-stable-noarch requires centreon-bi-etl >= 22.10.0, but none of the providers can be installed - package centreon-bi-reporting-server-22.10.8-1.el8.noarch from centreon-business-22.10-stable-noarch requires centreon-bi-etl < 22.11.0, but none of the providers can be installed ? thanks for help Andreas
Seeing some issues with 23.10.{9,10}. I can’t delete services groups or even edit existing ones. Basically after I confirm to delete, page goes blank and nothing was deleted. This is holding me up from adding monitoring right now because I can’t create new service groups.I tried tailing logs, journalctl, everything in /var/log. I see no errors when the page fails unfortunately.Actually, the most I’ve seen log wise which seems to correlate to when I get the failed page:mariadbd[6018]: 2024-03-05 23:01:31 35635 [Warning] Aborted connection 35635 to db: ‘centreon’ user: ‘centreon’ host: ‘localhost’ (Got an error reading communication packets)Any idea what this could be? It seems to only be limited to Service Groups.Upgraded to the testing version. No change.Acknowledging alerts seems broken as well.There is a host entry I deleted, yet still shows up in the resource list with service checks associated with it, even though I deleted the host. Feels like the db is out of step or somet
Hi Guys, I am contacting you to ask for more information about how a poller works in reverse ZMQ.Ports to use are 5556 and 5669.When Central and Poller are connected for he first time, could you, please, tell me who initiates the connection first?Is it the poller that connects to the central first to send the request to the central (SYN-SENT) ? Your answear will be appreciated !! Another question :) We use HAProxy as a proxy for publication.Could you tell me if a specific rules need to be set in it ? Thank you in advance, Have a nice day Heritiana
After Created my Centreon 23.10 repository on my Redhat SatelliteI have launched on my Rhel 8 Server the command : dnf install centreon on the Central ServerBut i’m block with some unavailable paquets.Do you know where coudl be my issue ?Problem: package centreon-23.10.9-1.el8.noarch requires centreon-central = 23.10.9-1.el8, but none of the providers can be installed - package centreon-central-23.10.9-1.el8.noarch requires centreon-poller = 23.10.9-1.el8, but none of the providers can be installed - cannot install the best candidate for the job - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.0-1.el8.noarch - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.0-1.el8.noarch - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.1-1.el8.noarch - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.1-1.el8.noarch - nothing provides nagios-plugins-icmp >= 2.0.
Hello everyone,What rights should be added so that a standard user can change their password?I added "my account" in the settings,but the little gear wheel does not appear…thank you for your feedbackSincerely
I have a centreon on an almalinux machine, I am currently monitoring a virtual NAS the host checks are correct but when I try to integrate my host machine into it a basic windows it works 1 time out of 2, I don't understand where it comes
Hello everyone,I'm reaching out to the community for some guidance on managing user permissions in Centreon. In our organization, we need to allow certain users (who should not have global admin rights) to be able to add, edit, and delete monitoring plugins in Centreon. The goal is to give them some autonomy in managing plugins without giving them full control over the system.I've looked through the documentation and configuration settings but haven't found a clear solution on how to set these specific permissions. Has anyone implemented a similar setup or can guide me on the best approach to this configuration?Here's what we're looking to achieve:The designated users should be able to add new monitoring plugins to the system. These users should also be able to modify the configurations of existing monitoring plugins. They should be able to delete monitoring plugins if needed. However, it's crucial that these permissions are limited to monitoring plugins management only, without provid
I need to create a check command that launches a script but passing it the user who is logged in that session. I've been looking in the macros but I can't find any that give me this possibility.Can you help me? Regards,
I created a host group for my linux vms. then i created a service group with linux snmp based services. I then added this service group to a host group by creating a new services for host group. But the associated services monitoring didnt start . Only the check command is triggered in services but associated service templates in the service group didnt get triggered. please help.
Bonjour ,Je viens de suivre la documentation pour installer un centreon 23.10 sur un Debian 11 et la mise en place c’est bien passé , aucune erreur .Par contre , lorsque je veux ajouter un nouveau “HOST” , il n’apparait jamais âpres un export classique du Central.Je suis obligé de relancer les services par la commande suivante pour que cela fonctionnesystemctl restart cbd centengineMerci pour votre aidecdt.
Hello! I was updating my database server and wanted to dump the centreon database. After the job was finished, I removed BOTH the dump and the centroen db.the centreon_storage db is still there - and i cannot see any issues in the app - which is installed on a different server (db is on another one). what could i do now?
Hello,I already had a problem with the mysql database, I have a check service for windows VMs which are very greedy for space,I had increased the size of this space in the past, but I have the problem again. Would you know how to clean the database, or at least an old part of it?Best regards,
Bonjour,J’aimerai savoir si c’est posssible d’annuler le dernier push (avec export discovery) pour revenir au précedent. Si c’est le cas comment puis je faire.Parce que j’ai fait des modifications que j’aimerai enlerver….Cordialement,
Hi,As you can see in the log below the validity of the licence is checked (twice ?) every twenty second or so, the token is refreshed.It spams the debug logs (and that’s a problem). What the point to do this check so often? This is crazy.[2024-03-20T14:01:20+0100] [DEBUG] [EventSubscriber\UpdateEventSubscriber:69]: Checking if route matches updates endpoint[2024-03-20T14:01:20+0100] [DEBUG] [Core\Security\Authentication\Infrastructure\Repository\DbWriteTokenRepository:61]: Deleting expired refresh tokens[2024-03-20T14:01:20+0100] [DEBUG] [Core\Security\Authentication\Infrastructure\Repository\DbWriteTokenRepository:82]: Deleting expired tokens which are not linked to a refresh token[2024-03-20T14:01:50+0100] [DEBUG] [EventSubscriber\UpdateEventSubscriber:69]: Checking if route matches updates endpoint[2024-03-20T14:01:50+0100] [DEBUG] [Core\Security\Authentication\Infrastructure\Repository\DbWriteTokenRepository:61]: Deleting expired refresh tokens[2024-03-20T14:01:50+0100] [DEBUG] [Co
Hello,We are using Centreon 2.5.4 (cbd, nagios,etc...) and the various servers are running Centos 6.11.We have a central server, several poller servers and a mysql server.We encountered a problem with our VMs and had to restore them from a snapshot.Since then, we've been unable to start the cbd service (/etc/init.d/cbd) on the poller servers. They start, but after a synchonization with the central server, it ends up stopping after a 60s timeout with the following error: error: TCP: error while writing: Socket is not connected On the central server, the cbd service is running fine.Do you have any idea why this error occurred? Best regards,Kevin Pemonon
Hello, i want to use an opensource version of CENTREON, but is there any limitation with the number of host or metrics ?
Hello,I freshly upgraded Centreon from 23.10.3 to 23.10.10 and I now can’t create dashboards. Also, my previous dashboards are deleted.When i go to the dashboard page i have this message in red at the bottom of the page :decoder failed at key "result" with error: decoder failed at index "3" with error: decoder failed at key "createdBy" (mapped from the JSON key "created_by") with error: null is not a valid Created By Do you know where i should start my troubleshooting ? Thank you for your help.
Bonjour,J’installe un nouveau serveur en suivant la documentation pas à pas et lors de l’installation du central (avec bdd), le dnf install centreon install le paquet mariadb-server (qui est en 10.3) alors que la 22.10 nécessite maraidb 10.5 (qui est reconnu avec le paquet MariaDB-server et pas mariadb-server). Est-ce que je dois installer d’abord mariadb en 10.5 ou installer mariadb en 10.3 puis faire le saut 10.3 > 10.5 ou corriger les dépendances de l’application centreon ? Cdlt,
Hi,I'm trying to collect some metrics from Google Compute APIs but cannot figure out how to use the plugin.I got error code 400, maybe my filters are wrong...## How to reproduce- **Environment**:result of `uname -a ; cat /etc/redhat-release /etc/debian_version`:```Linux server.domain 4.18.0-477.21.1.el8_8.x86_64 #1 SMP Thu Jul 20 08:38:27 EDT 2023 x86_64 x86_64 x86_64 GNU/LinuxRed Hat Enterprise Linux release 8.8 (Ootpa)```- **Version of the plugin**: `20240311-143354.el8`- **Information about the monitored resource**: Google API- **Command line**:```./centreon_gcp_management_stackdriver_api.pl \ --plugin=cloud::google::gcp::management::stackdriver::plugin \ --mode=get-metrics \ --key-file=key.json \ --dimension-name=metrics.labels.instance_name \ --dimension-operator=equals \ --dimension-value=NAME \ --metric=instance/cpu/utilization \ --api=compute.googleapis.com \ --warning-metric=90 \ --critical-metric=95 \ --verbose \ --proxyurl=http://proxy.domain:9090 \ --http-backe
Good morning,We are in the process of setting up supervision via the HTTP-Collection plugin and we cannot figure out how to make a filter in the "selection_loop" section which allows a selection to be made when the field contains a defined character string .Example: "filter": "%(http.tables.request1) = ‘*chaine*’"Thanking you for the help
Bonjour, Nous avons migré notre solutions Centreon il y a quelques temps déjà d’une version obsolète à la dernière version stable.Tout fonctionne correctement dans l’ensemble mais nous rencontrons quelques problématiques.En effet, certains hôtes/services semblent bugués après import et ceux ci ne prennent pas en compte les modifications.Y’a il une façon de nettoyer/vérifier la base de données ou y’a il des endroits où je peux vérifier afin de trouver l’origine de l’anomalie ? Merci d’avance
It's been 5 months now since we released Centreon 23.10. If you have not adopted this version yet, please check the Product Updates article for more details.
Bonjour à tous,Nous mettons en place plusieurs check CENTREON avec des scripts Externes Powershell.Le dernier en date me pose problème et je ne sais pas où chercher.Quand il est exécuté via un compte admin local ou admin du domaine, tout fonctionne correctement.Cependant, lorsque je l’exécute avec NRPE3, j’ai un bout de code qui ne réagi pas normalement.Le script fait :Récupération de la dateRécupération de la taille d’un fichierExport CSV dans un tableau avec colonne SIZE et DATE.Après, calcule pour vérifier si le fichier a grossi + pourcentage associé.Mon problème est dans l’export.Lancement du script depuis le serveur avec un compte admin local ou admin du domaine, j’ai bien la taille et la date.Mais avec NRPE3, la date ne s’inscrit pas dans le fichier CSV.Quelle différence il y a t il entre les 2 exécutions pour avoir ces 2 résultats ? Merci de votre aide !
All other services are Ok just can,t able to monitor Cluster_status/usr/lib/centreon/plugins/centreon_vmware_connector_client.pl --plugin=apps::vmware::connector::plugin --mode=status-cluster --custommode=connector --connector-hostname='localhost' --connector-port='5700' --container='default' --cluster-name='.*' --filter --unknown-status='%{overall_status} =~ /gray/i || %{vsan_status} =~ /gray/i' --warning-status='%{overall_status} =~ /yellow/i || %{vsan_status} =~ /yellow/i' --critical-status='%{overall_status} =~ /red/i || %{vsan_status} =~ /red/i' --verboseand log is 'default' SOAP request error - possibly a protocol issue: Server closed connection without sending any data back at /usr/share/perl5/vendor_perl/Net/HTTP/Methods.pm line 391.please HelpRegard
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.