Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,I have a central server and a remote server. On the central server I can see the pollers are running but the hosts from the remote server all show ‘unreachable’. On the remote server I can see that the hosts are all ‘up’ and reporting correctly.On the remote server under platform status > broker statistics on the remote server I can seeforward-to-master is stuck on ‘connecting’On the central server I can see it is ‘listening’ On the central server I can see both pollers are running: What should I be checking to diagnose the lack of communication between the two?I do not see any errors on the remote servers gorgoned.logon the central servers gorgoned.log I see the following:ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - cannot decode json response: malformed JSON string, neither tag, array, object, number, string or atom, at character offset 0 (before "<!DOCTYPE HTML PUBLI...") at /usr/share/perl5/vendor_perl/gorgone/class/tpapi/centreonv2.p
Hello everyone,I am currently installing Centreon for my company.So I have a little question :)Would it be possible to activate pam_ldap on AlmaLinux 8 in order to connect with AD on Centreon?
On my test Centreon v23 I was notified that some Connectors needed updating so I proceeded.Some errors popped up for the Generic SNMP connector but after waiting and pressing OK everything looked to be fine. On closer inspection I noticed several extra ones that we did not have before, nor do we require have now also been installed:I cannot remove them either - it seems to go through the motion and the green installed icon disappears, but after a refresh they all come back. No messages are displayed and none of them are used by any hosts, using the re-install button has no effect. Rebooting the RHEL8 server does not help.How can I get rid of them?
Dear Thewatch community, Following an advice given by the technical guy from centreon support. I will try to explain my issue.I tried to monitor the SAN Netapp Solidfire without any success.First of all using SNMP queries, i must say that everything is ok when i use snmpwalk.Then using the RESTAPI which seems a bit different than in the plugin. So, my question is it planned a day to make the plugin compatible with this SAN ? Or should I forgive it and prepare to make my check by getting the OID for each control. Many thanks for your advices. BR,
hellowe recently deployed some hyper-v nodethey are running windows 2022 with centreon-nsclient 5.2.41 and they have more than 64 thread the cpu check return abnormal value : this is probably a bug from the NSClient program, but has anyone encountered this problem and managed to fix it? Thanks in advance
Hi guys, Since a couple of days, ldap access doesn’t work anymore. login.log reports “Authentication failed for 'xxx' : invalid credentials”ldap.log reports “LDAP AUTH - Error : No DN for xxx” ldap user import still is working properly Any help would be appreciated. Thanks J.
Hi Team,Let me know how to configure SMTP settings on Centreon cento OS server for email alerts to internal system admin.Request your hlep . thanks.
Centreon server is ready , want to monitor Windows servers 2019 and 2016 , how to do it.
Hello,My centreon broker log are flooded with this mysl_connection error .all seem to be ok ,mariadb is up and running. Centreon working as well . can you tell me where it come from ? [2023-09-06T15:37:06.568+02:00] [sql] [error] mysql_connection 0x7f790b4441b0: error while starting connection: mysql_connection: The mysql/mariadb database seems not started. Waiting before attempt to connect again: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)[2023-09-06T15:37:06.568+02:00] [core] [error] failover: global error: mysql_connection: error while starting connection[2023-09-06T15:37:21.570+02:00] [sql] [error] mysql_connection 0x7f790b4441b0: error while starting connection: mysql_connection: The mysql/mariadb database seems not started. Waiting before attempt to connect again: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)[2023-09-06T15:37:21.570+02:00] [core] [error] failover: global error: mysql_connection: error
Hello community, I have received an alert from Microsoft Defender SmartScreen while downloading centreon-nsclient from the Centreon GitHub page. A feedback form was available and I used it to declare the webpage as safe. Has anyone else received such alert? Élodie.
Hey has anyone been able to monitor free pbx from there servers ? I’m currently using newest v23. I just can’t seem to find anything.Free PBX uses Sangoma Linux 7
Hello friends. Your help is needed. For the cluster-events mode of the plugin I mentioned, we need examples of the command.Command :/usr/lib/centreon/plugins//centreon_kubernetes_api.pl --plugin=cloud::kubernetes::plugin --mode=cluster-events --custommode='kubectl' --hostname= --port='' --proto='' --token='' --config-file='/var/lib/centreon-engine/.kube/config' --proxyurl='' --timeout='' --filter-type='' --filter-namespace='' --warning-status='' --critical-status='' --verbose What should I do to make it appear when there are errors?'%{type} =~ /warning/i''%{type} =~ /error/i'
Hello community, I try to say if it’s possible to monitor a port from a host to another. I have a AAA server and I need to be sure this server can communicate with server BBB using the port XXXX. Is it possible in Centreon and if yes, how? :-) Laurent
Hello the community, I try to execute a custom script but It seems I miss something. I have a poller on an ec2 instance on AWS. I try to execute a probe Python script on a Linux server on another ec2 instance. this server is attached to the poller in AWS.The script is located on server (not on the poller)Locally, the script works fine.But via Centreon, I have “(Execute command failed)” Other non-custom probes are working well. Can you help me to understand? Regards, Laurent
Hello,I would try centreon to monitoring AS400 ibm i server but i have many troubleshooting.I can ping my host AS400 with the base_host_alive command.I have IBM AS400 Connector installed.I try to create a CPU service with OS-AS400-CPU command for an host but he have an unknown status with (No output returned from plugin).Someone can help us ?Best Regards
My Centreon server suddenly started consuming 400% of the server's CPU. When I checked with top command I noticed that the issue was related to MariaDB. Then, I used mysql to list the process list, and I found several processes associated with the Centreon user. Most of these queries were identical SELECT statements. What could be causing this? How can I resolve the problem?
Hi,I’ve seen there are two other topics with a similar problem but as they’re quite old I make this new one.The problem is: the Engine JSON stats file (named pipe) is missing on one of our poller. A restart of the centreon-engine service fixes the issue.I checked both the broker log and the engine log and found no error, no error in /var/log/message either.I wonder if anyone already has got this issuen and if it’s a known issue. If so, how I could avoid it.Engine log levels are the following: Engine log levelsand Broker log level are: Broker log levelsPackage versions are:centreon-broker-22.10.4-1.el8.x86_64centreon-broker-cbmod-22.10.4-1.el8.x86_64centreon-broker-core-22.10.4-1.el8.x86_64centreon-broker-selinux-0.0.5-1.x86_64centreon-broker-storage-22.10.4-1.el8.x86_64centreon-clib-22.10.4-1.el8.x86_64centreon-common-22.10.11-1.el8.noarchcentreon-common-selinux-0.0.10-1.x86_64centreon-connector-22.10.4-1.el8.x86_64centreon-connector-perl-22.10.4-1.el8.x86_64centreon-connector-ssh-22.1
Hello,The status of all my ESXs are unknown “overall status is gray” Here you can see the current configuration:is it correct? Can someone please help me ?
Hello,I configured oidc with AzureAD bu i’m facing a strange behavior, depending on the browser I use: Google Chrome: OK in normal mode, OK in private modeEdge: KO in normal mode, OK in private modeFirefox: KO in normal mode, KO in private mode What I mean for KO is the following beahvior:After clicking on “Se connecter avec openid” button, connection is made, user/role is logged like this: but in browser, I am redirected to the login page. I tried to activate debug logs and I found a difference in centreon-web.log between “working” and “not-working” cases. working case (Google Chrome) NOT working case (Mozilla Firefox) Test have been made using a brand new vmware install of centreon updated to v 23.04.7
Hello everyoneI remarque event logs on version 23.04.6 doesn’t work. I check the others topics where a solution is provided, but that solution doesn’t apply to me. Do you have a solution for these issues?Best Regards
Hello, I am pretty begginer in this area, but I would try to learn more. It monitors disk occupancy at 99% by giving Critical and Warning limits in percent. In contrast, I recently had to change from % to Byte. After this change, the monitoring works properly, but the displayed chart no longer does. How it was set and look like:/usr/lib/nagios/plugins/centreon-plugins/centreon_plugins.pl --plugin=os::windows::snmp::plugin --mode=storage --hostname=10.10.10.10 --snmp-version='2c' --snmp-community='Test' --storage='D:' --name --display-transform-src='^(..).*' --display-transform-dst='$1' --warning-usage='85' --critical-usage='90' --explode-perfdata-max='used,size' --filter-perfdata='size|used|free' --regexpGraphics chart looks like this After changing to ranges in bytes (graphics is just example - diffirent disk):/usr/lib/nagios/plugins/centreon-plugins/centreon_plugins.pl --plugin=os::windows::snmp::plugin --mode=storage --hostname=10.10.10.10 --snmp-version='2c' --snmp-community='Te
Hello everyone,I don’t have any output on administration > Platform Status >Databases.Do you have an idea why i have this problem ?Best regards
Hello,after upgrading RHEL8.7 from Centreon 3.4 to latest 22.10, Im unable to export CSV performance data from graphs. Once I click on the button (see picture below). I get redirected to a page; which indicates the page your tried to access has being iternal error occurered or the web page has moved to the new web page completely - same thing happens if I export CSV directly from performances page. Oddly exporting timeline and graph pictures works fine.
et quand j’ajoute le token fourni par centreon pour une licence IT-100j’ai : Je n’ai pas de fichier epp.license.
Hi,I had trouble duplicating hosts from the Web UI. Every time I try to duplicate a host with associated services, the services for the duplicated hosts aren’t displayed for the user account, but I can see them with the admin account.I’ve the centreon’s 23.04.6 version running on debian bullseye.Waht’s supprising is that, when I create the hosts from scratch, and choose to deploy linked services, it works fine.I’ve checked all the configurations for my user account, and it seem to have every right needed to do what I want. And I couldn’t figure out what’s happening.Do anyone have a clue ou can give me some hints on where to look at ?Thanks in advance for your help.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.