Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
[2026-01-22T09:15:29+0100] [ERROR] An error occurred during authentication {"custom":{"trace":"Core\\Security\\Authentication\\Domain\\Exception\\SSOAuthenticationException: [openid]: Login claim [email] not found from external provider user in /usr/share/centreon/src/Core/Security/Authentication/Domain/Exception/SSOAuthenticationException.php:122\nStack trace:\n#0 /usr/share/centreon/src/Core/Security/Authentication/Domain/Provider/OpenIdProvider.php(839): Core\\Security\\Authentication\\Domain\\Exception\\SSOAuthenticationException::loginClaimNotFound()\n#1 /usr/share/centreon/src/Core/Security/Authentication/Domain/Provider/OpenIdProvider.php(294): Core\\Security\\Authentication\\Domain\\Provider\\OpenIdProvider->getUsernameFromLoginClaim()\n#2 /usr/share/centreon/src/Core/Security/Authentication/Infrastructure/Provider/OpenId.php(79): Core\\Security\\Authentication\\Domain\\Provider\\OpenIdProvider->authenticateOrFail()\n#3 /usr/share/centreon/src/Core/Security/Authentication
Bonjour,Je demande à l’aide car je sèche depuis plusieurs jours de recherche 😑J’ai lu la doc DSM, debug la partie SNMP, mais j’en arrive toujours au même, les slots restent en status pending et lors de la réception d’une trap j’ai le message dans les log dsm ERROR - [find_slot_id] cannot find slot [alarm id = 23132##APBUREAU [host id = 200] [pool prefix = AP] La partie trap SNMP est ok, le service passif est bien configuré et relié. Je ne trouve pas de problème de configuration.
Can you confirm the EOL for the Centreon MAP module ?I think it’ll be replaced by the Dashboard
When youd edit a host with a snmp community (update) the frontend shows ******* (obfuscated) snmp community.Since 24.10.14 the old php code handles this correct.In the latest minor version the "update host" has changed to be saved via API. The API doesn't handle the ****** for the comunity and saves it to the database.reproduce:create new host on version 24.10.16correct in the DBopen the host again and save it the community is saved with *******https://github.com/centreon/centreon/issues/9257
Bonjour,j’aimerai pouvoir checker mes disques avec des seuils exemples warning 30 gb restants et critique 15 gb restant plutôt que des %.$CENTREONPLUGINS$/centreon_windows_snmp.pl --plugin=os::windows::snmp::plugin --mode=storage --hostname=$HOSTADDRESS$ --snmp-version=$_HOSTSNMPVERSION$ --snmp-community=$_HOSTSNMPCOMMUNITY$ $_HOSTSNMPEXTRAOPTIONS$ --regexp --name --storage '$_SERVICEDISKNAME$' --display-transform-src='$_SERVICETRANSFORMSRC$' --display-transform-dst='$_SERVICETRANSFORMDST$' --warning-usage='$_SERVICEWARNING$' --critical-usage='$_SERVICECRITICAL$' $_SERVICEEXTRAOPTIONS$ --explode-perfdata-max='^used$,size'voici la plugin utilisé est ce que qql pourrait m’aider ?Merci à vous.
Hello everyone,I am unable to configure SAML authentication with Entra ID. I am attaching screenshots of the configuration. Can you help me, please?
Hello,What are the best practices for warning critical values, etc.?Given that, for example, 80% of a 100GB disk is more alarming than 80% of a 1TB disk, how can these values be classified and adjusted?Thank you in advance for your answers/ideas.
après la migration vers 24.04 au 25.10j’ai créé les connecteurs ici le service centreon_vmware ne démarre plus sur tous mes pollersça ne démarre que sur centralela seule différance est que sur centrale le fichier /etc/centreon/centreon_vmware.json contient les username et passeword encrypted{ "vsphere_server": [ { "name": "vcenter-test1", "url": "https://vcenter.test1.com/sdk", "username": "encrypt::TDQLjVlC/mHvp1h+aJzdINBVVasRz3Cpi1ryLbS1h1NW1M808iSpCtzLBesOPR4thHDgJfj0aAVZ4fDWS+HshL8YOMmujdXa1aOwHInUUfLglL2vACmGssWX3EDGa23YSJ5zA==", "password": "encrypt::2xmayFYRqYJptSKW58qjzrDIUsBXuWvZY5ofx8vNU99IkHvnRK+hov7bJZmOe/3XWnBY7qe20Fo3GB1Fjn6unkLL4puz7CwD7NbMGFuXMpuxKh0v4Z2nxGYJXcwdh+oRevhxifnr7nfO/qg==" }, { "name": "vcenter-test2", "url": "https://vcenter.test2.com/sdk", "username": "encrypt::ncFsUz6ObFq+3t1KK3gP5uApcm8c78b2k8P6hp8Gp9ZFkkLYc55/uwxwHfuyGQwZLED0WDm4M+dVuQ==", "p
Hello, would it be possible to include the client name in the output of the plugin centreon_commvault_commserve_restapi.pl?Currently, the output when using the modifier --filter-type='type' is as follows: CRITICAL: 2 problem(s) detected | 'jobs.total.count'=9;;;0; 'jobs.problems.current.count'=2;;;0; Checking policy 'DR Importance 2 (OR)_ReplicationPlan' Checking policy 'DR Importance 3 (OR)_ReplicationPlan' Checking policy 'SP_01_KEU_60Days' Checking policy 'notAvailable' critical: Job '878573' [Client: , type: Type] status: Failed to Start critical: Job '878575' [Client: , type: Type] status: Failed to Start The last part, where the failed job is specified, does not indicate the corresponding client name.Would it be possible for these last lines (where the failed job is shown) to also include the associated client name?
Hello,I noticed that in previous versions of Centreon MAP, it was possible to display link status directly on Geographic Views.This functionality is described in the following article:https://www.centreon.com/provide-real-time-it-infrastructure-status-overviews-with-centreon-map-to-your-itom-teams-and-operational-users/However, in the current New Web MAP, I am unable to find this option. It does not seem to be available anymore, or I may be missing the configuration.Could you please confirm whether this feature is still supported in the new MAP interface, and if so, how it can be configured?Thank you for your assistance.Best regards,Moorshid
Bonjour,Je viens de migrer mon centreon 22.10 vers 25.10 centos7 vers Debian12. Tout est parfaitement fonctionnel mis à part les macros des services par groupe d’hôtes qui ne sont plus interprétées et non présentes dans le fichier /etc/centreon-engine/services.cfgEn revanche les macros des services par hôtes et les macros d’hôtes sont elles bien interprétées et présentes dans les fichiers de config.Est ce qu’il y a un changement dans la prise en charge de ses macros ?J’ai essayé de passer par des templates pour mettre les macros mais comme se sont des templates lées à des services de groupes d’hôtes le résultat est le même. Merci pour vos retours
Hello, Does anyone have any idea what this could be? /var/log/php-fpm/centreon-error.logcentreon 24.10.16 [Jan 13, 2026 3:11:22 p.m. CET] [2026-01-13T15:11:22+0100] [WARNING] Warning: Undefined array key 650 {“exception”:“[object] (ErrorException(code: 0): Warning: Undefined array key 650 at /usr/share/centreon/src/Centreon/Infrastructure/Contact/ContactRepositoryRDB.php:331)”}[Jan-13-2026 15:11:22 CET] [2026-01-13T15:11:22+0100] [WARNING] Warning: Trying to access array offset on value of type null {“exception”:"[object] (ErrorException(code: 0): Warning: Trying to access array offset on value of type null at /usr/share/centreon/src/Centreon/Infrastructure/Contact/ContactRepositoryRDB.php:331)"} /var/log/php-fpm/centreon-error.logthanks
Hello,I'm using monitoring via a.From the console (using centreon-engine), the response is correct.However, from the management interface, I get the message "option '63' requires an argument".I don't understand why this is an incorrect message.Thank you for your help.Eric
Hello Seems like https://packages.centreon.com/ui/native/rpm-standard/22.10/el8/centreon-22.10.repo is missing. Im still using it , part of an automation. ["Status code: 404 for https://packages.centreon.com/rpm-standard/22.10/el8/centreon-22.10.repo (IP: 10.0.9.23)", "Error: Configuration of repo failed"], "stdout": "Adding repo from: https://packages.centreon.com/rpm-standard/22.10/el8/centreon-22.10.repo", "stdout_lines": ["Adding repo from: https://packages.centreon.com/rpm-standard/22.10/el8/centreon-22.10.repo"]}Can someone from Centreon team fix ?
Bonjour, Je travaille sur la modélisation d’une map sur le base d’objet de type “hostgroup”Mon but est de remonter le status des hôtes ( up/ dowwn )Est-il possible de n’afficher que les status des hotes ( pas des services liés) sur une map ?Je ne trouve pas d’options sur l’objet hostgroup.. et pas de possibilité au niveau de l’objet host de sélection des hostgroupsMerci de votre aide…
Can Graph be configured to display the granularity? For example, the current display interval is every 5 minutes. Can it be changed to 1 minute? Thank you.
HelloI recently had to change the authentication method on a centreon web setup to activate m365/EntraID saml login.Thanks to the fix to the UI to implement the “strict” method, it works without editing the PHP files like before, however there are some issues depending on how you have setup your m365 accountCase 1 : no MFA, simple login/password (that’s bad) <= saml with Entra worksCase 2 : you activated your MFA, and do not use windows hello, so you still use you login/password in your browser <== saml with Entra worksCase 3 : you went full mfa, no password, windows hello/fido, identify token, so you are never typing a password to login into microsoft entra <== saml with Entra does not work when login in an already authenticated browser AADSTS75011: Authentication method 'X509, MultiFactor, X509Device' by which the user authenticated with the service doesn't match requested authentication method 'Password, ProtectedTransport'. Contact the application owner. when login into a
Hi,I am looking for an advice on the best approach for the following.We currently have a linux server producing a custom metric for an internal application. This metric is currently simply logged in a file on the server.I was wondering if I could not use centreon for basic monitoring of this metric. To have alerting and easy historic access with a graph.I suppose there is different possibility for that. Maybe transform this metric into a custom snmp information that could be recovered by centreon for exemple. Or via the nrpe plugin. I was wondering what you would recommend to avoid as much customisation as possible and keep it as simple as possible.The real solution is to have observability of the app with something like open telemetry standard but this is too early for now. Regards,
J’ai un problème j’ai migré de version actuellement sur la dernière en liste. sur mon centreon de test celui en prod étant en ancienne version. Cependant sur awx j’ai cette erreur pourtant rien n’a changé à part la version je n’arrive pas à comprendre si le soucis viens d’awx ou centreon. \"/tmp/ansible_centreon_host_payload_hvia7iww/ansible_centreon_host_payload.zip/ansible/modules/centreon_host.py\", line 416, in main\n File \"/var/lib/awx/venv/ansible/lib/python3.6/site-packages/centreonapi/webservice/configuration/host.py\", line 409, in getparams\n return self.getparam(centreon_host_params)\n File \"/var/lib/awx/venv/ansible/lib/python3.6/site-packages/centreonapi/webservice/configuration/host.py\", line 389, in getparam\n current_param[p.split(\":\", 1)[0].strip()] = p.split(\":\", 1)[1].strip()\nAttributeError: 'dict' object has no attribute 'split'\n", "msg": "MODULE FAILURE\nSee stdout/stderr for the exact error", "rc": 1,}
Hello,I was able to follow the procedure step by step, as described in the online documentation, to migrate from version 24.04 to 25.10.The migration completed successfully; however, I am encountering an error when applying the configuration on the central collector : [ - ] SRVA-CES1protocols: registering protocol ('file' (layers 1-3)protocols: registering protocol ('compression' (layers 6-6)protocols: registering protocol ('BBDO' (layers 7-7)endpoint applier: loading configurationReading main configuration file '/var/cache/centreon/config/engine/1/centengine.DEBUG'.The option 'auto_rescheduling_interval' is no longer available. This option is deprecated.The option 'auto_rescheduling_window' is no longer available. This option is deprecated.The option 'auto_reschedule_checks' is no longer available. This option is deprecated.Reading resource file '/var/cache/centreon/config/engine/1/resource.cfg'Warning Service 'Swap' on host 'ARCHIVESA-01' has a notification interval less than its ch
Bonjour à tous,Je vous souhaite une très bonne année pleine de succès et de réussite.je commence cette année avec une tentative d’upgrade de centreon de la version 24.04 vers 24.10 ou 25.10 mais j’ai exactement les mêmes messages d’erreur. - nothing provides perl(Mojo::IOLoop::Signal) needed by centreon-gorgone-24.10.7-1.el9.noarch from centreon-stable-noarch-rh9 - nothing provides perl(Mojo::IOLoop::Signal) needed by centreon-gorgone-24.10.2-1.el9.noarch from centreon-stable-noarch-rh9 - nothing provides perl(Mojo::IOLoop::Signal) needed by centreon-gorgone-24.10.5-1.el9.noarch from centreon-stable-noarch-rh9 - nothing provides perl(Mojo::IOLoop::Signal) needed by centreon-gorgone-24.10.6-1.el9.noarch from centreon-stable-noarch-rh9 - nothing provides perl(Mojo::IOLoop::Signal) needed by centreon-gorgone-24.10.4-1.el9.noarch from centreon-stable-noarch-rh9 - nothing provides perl(Mojo::IOLoop::Signal) needed by centreon-gorgone-24.10.3-1.el9.noarch from centreon-stable-noarch-rh
Dear users, In order to simplify and improve the user experience of our software, we plan to remove two features in an upcoming major update:Creating services linked to multiple hosts. Creating services by host group.We understand that these features may still be used by some of you, but we believe they can be replaced by the use of templates. We are making this decision to optimize the software and make it more intuitive. Proposal of solutions when updating the Centreon platform Services linked to multiple hostsCreating a service linked to multiple hosts allows you to have an identical configuration of this service for multiple hosts.This service can be transformed into a service template. A single service will be created for each linked host and will inherit the template you previously created.This update will be performed automatically during the Centreon platform update process (target: Centreon 25.10). Services by Host GroupCreating a service by host group allows for the same serv
We are facing an issue with the centreon_vmware process that started after a Centreon update applied in mid-December.Issue descriptionThe centreon_vmware service fails to start with the following error:# systemctl status centreon_vmware.servicecentreon_vmware.service - Centreon VMWareLoaded: loaded (/lib/systemd/system/centreon_vmware.service; enabled)Active: failed (Result: exit-code)Process: ExecStart=/usr/bin/perl /usr/bin/centreon_vmware.pl $OPTIONSStatus: 255/EXCEPTIONCan't use string ("Could not decode JSON from ''...") as a HASH refat /usr/share/perl5/centreon/script/credentialsencryption.pm line 55.LogsThe centreon_vmware.log shows the following messages:No vault config file given. Applying default: /var/lib/centreon/vault/vault.jsonNo Engine context config file given. Applying default: /etc/centreon-engine/engine-context.jsonThe given configuration file /var/lib/centreon/vault/vault.json does not exist.Something happened during init() method that makes Centreonvault not usable
Hello,Since the upgrade from 24.10 to 25.10, all ping services no longer work.I am using the “Base-Ping-LAN” template and the “base-centreon-ping” command.Linux ALMALINUX 9Over SSH, all my pings work correctly. In my firewall, ICMP traffic passes correctly.Version 25.10.4Was there any change between 24.10 and 25.10?How can this be resolved?I also set up a new VM and a clean installation of Centreon 25.10, I added a host for ping and I'm having the same issue.---------------------Français---------------BonjourDepuis le passage de 24.10 à 25.10, tous les services ping ne fonctionnent plusJ’utilise le modèle “Base-Ping-LAN” et la commande “base-centreon-ping”Linux ALMALINUX 9 En SSH, tous mes pings fonctionnent correctement. Dans mon firewall les flux ICMP passent correctement.Version 25.10.4Y a t’il eu un changement entre 24.10 et 25.10 ?Comment solutionner?J’ai aussi installé une nouvelle VM et une installation propre de centreon 25.10, j’ai mis un hote en ping et j’ai aussi le même sou
Hello everyone,I’m encountering an issue with the display of CMA data on the “Resource Status” tab. Context 1 — When Centreon was installed, two ACLs were created: “User” and “Admin” (I really mean the ACL, not the “Admin” option you can check on the user profile under the “Authentication” tab). The “User” ACL has limited access, but the “Admin” ACL has all permissions enabled across all ACL tabs. And of course, my admins are in the correct group associated with this ACL. Context 2 — We deployed several CMAs on servers, and they are fully visible in Centreon — everything works fine. My question is the following: Why can users with the “Admin” ACL (with everything checked) not see the CMA resources on the “Resource Status” tab, while a user with the “Admin” option enabled on their profile can see them? How can I allow the “Admin” ACL to access CMA resources? I think I’m missing something, which is why I’m asking for your help now. :) We have a Centreon 24.10 on a Debian 12 up to date. T
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.